[Bug 889398] hedgewars: embedded freetype (2.4.4) vulnerable to many flaws [fedora-all]

bugzilla at redhat.com bugzilla at redhat.com
Fri Dec 21 22:04:19 UTC 2012


Product: Fedora
https://bugzilla.redhat.com/show_bug.cgi?id=889398

--- Comment #5 from Bruno Wolff III <bruno at wolff.to> ---
There's definitely something odd about how that library gets pulled in. It
didn't look like any of the buildrequires should pull in freetype-devel, but
yet it gets pulled in. I checked using repoquery --recursive --whatrequires
freetype-devel and didn't get any matches.

On the plus side, when looking at this I noticed a minor feature was disabled
because libpng-devel wasn't listed in a buildrequires. So I fixed that. And I
figured it was time to update to 0.9.18 in f16 and f17 so that people could
play network games (as mostly people use the latest version for those).

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Unsubscribe from this bug https://bugzilla.redhat.com/token.cgi?t=TgSgbVR7oB&a=cc_unsubscribe


More information about the fonts-bugs mailing list