[Bug 891457] uneven emulated Bold/Slant for subsetted large fonts

bugzilla at redhat.com bugzilla at redhat.com
Mon Jan 14 09:03:25 UTC 2013


Product: Fedora
https://bugzilla.redhat.com/show_bug.cgi?id=891457

--- Comment #25 from Hin-Tak Leung <htl10 at users.sourceforge.net> ---
(In reply to comment #24)
> (In reply to comment #23)
> > I Haven't tried, but I think it should work by replacing every "1000" with
> > "800" - since the code basically scale glyph co-ordinates up to x1000 then
> > round to integer. That does not answer why 1000 fails but 800 works though.
> 
> I compiled the latest freetype (2.4.11) and the test case now works
> correctly.
> 
> There seems to have been a few fixes to the emboldening code since 2.4.10:
> http://git.savannah.gnu.org/cgit/freetype/freetype2.git/log/src/base/ftoutln.
> c

upgrading to freetype 2.4.11 was the first thing I tried as well - it got worse
(some of the glyph has gone "reverse video"!). I'll upload that to show you.

The 64-bit version continue to work well, strangely.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Unsubscribe from this bug https://bugzilla.redhat.com/token.cgi?t=MJTldARi7v&a=cc_unsubscribe


More information about the fonts-bugs mailing list