[Bug 1216312] LilyPond crashes with Ghostscript 9.16

bugzilla at redhat.com bugzilla at redhat.com
Fri May 29 12:07:10 UTC 2015


Jon Ciesla <limburgher at gmail.com> changed:

           What    |Removed                     |Added
                 CC|                            |fonts-bugs at lists.fedoraproj
                   |                            |ect.org,
                   |                            |i18n-bugs at lists.fedoraproje
                   |                            |ct.org, tagoh at redhat.com
          Component|ghostscript                 |pango
           Assignee|jgrulich at redhat.com         |tagoh at redhat.com

--- Comment #5 from Jon Ciesla <limburgher at gmail.com> ---
Lilypond user on lilypond mailing list suspects pango:

> The Fedora 22 package fails for everyone, the www.lilypond.org version
> works.
> I tried this minimal example:
> % f22test.ly
> \version "2.19.21"
> {c'}
> And then did
> $ lilypond --ps --verbose f22.ly &> f22test1.txt
> $ ps2pdf14 f22test.ps f22test.pdf &> f22test2.txt
> results: see attachment.
> f22test1.txt f22test2.txt f22test.ps

Thank you for your files.

I suspect an issue of pango package of fedora 22.

First, I've tried your f22test.ps on my environment with gs-9.15.
It is failed. That is, it is not gs-9.16's issue.
The result is following.

$ ps2pdf14 f22test.ps f22test.pdf
Error: /undefinedresult in --glyphshow--
Operand stack:
   0.6146   5.6906   -2.8453   space
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1967   1   3   %oparray_pop  
1966   1   3   %oparray_pop   1950   1   3   %oparray_pop   1836   1   3  
%oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--  
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--   0  
--nostringval--   %repeat_continue   --nostringval--
Dictionary stack:
   --dict:1186/1684(ro)(G)--   --dict:0/20(G)--   --dict:108/200(L)--
Current allocation mode is local
Last OS error: No such file or directory
Current file position is 131424
GPL Ghostscript 9.15: Unrecoverable error, exit code 1


Then, I've found problems of f22test.ps.
Broken f22test.ps sets font size to zero.
Using the patch file for f22test.ps that is attached to this mail,
ps2pdf14 is succeed.

If I understand correctly, LilyPond gets the font size from pango.
www.lilypond.org version LilyPond bundles pango that has no problem,
and always uses it.

You are receiving this mail because:
You are on the CC list for the bug.
Unsubscribe from this bug https://bugzilla.redhat.com/token.cgi?t=bWsR3mWuAp&a=cc_unsubscribe

More information about the fonts-bugs mailing list