[Fedora-i18n-bugs] [eekboard] Update to 1.0.7-1.

Daiki Ueno ueno at fedoraproject.org
Fri Apr 13 07:53:16 UTC 2012


commit afec635cab4cf0df14bc924a2b0c9fdd2b09c2fe
Author: Daiki Ueno <ueno at unixuser.org>
Date:   Fri Apr 13 16:53:07 2012 +0900

    Update to 1.0.7-1.

 .gitignore    |    1 +
 eekboard.spec |   17 +++++++----------
 sources       |    2 +-
 3 files changed, 9 insertions(+), 11 deletions(-)
---
diff --git a/.gitignore b/.gitignore
index 16e4199..23dc4fb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -17,3 +17,4 @@ eekboard-0.0.5.tar.gz
 /eekboard-1.0.4.tar.gz
 /eekboard-1.0.5.tar.gz
 /eekboard-1.0.6.tar.gz
+/eekboard-1.0.7.tar.gz
diff --git a/eekboard.spec b/eekboard.spec
index 90fcb2c..3cc430f 100644
--- a/eekboard.spec
+++ b/eekboard.spec
@@ -1,17 +1,13 @@
 Name:		eekboard
-Version:	1.0.6
-Release:	2%{?dist}
+Version:	1.0.7
+Release:	1%{?dist}
 Summary:	Yet Another Virtual Keyboard
 
 Group:		Applications/System
 License:	GPLv3+
 URL:		http://fedorahosted.org/eekboard/
 Source0:	http://github.com/downloads/ueno/eekboard/eekboard-%{version}.tar.gz
-BuildRequires:	libfakekey-devel
-# older libfakekey-devel has missing BR: libXtst-devel (#680878)
 BuildRequires:	libXtst-devel
-# clutter build is currently disabled
-# BuildRequires:	clutter-gtk-devel
 BuildRequires:	gtk3-devel
 BuildRequires:	libxklavier-devel
 BuildRequires:	at-spi2-core-devel
@@ -54,7 +50,7 @@ This package contains the development tools for eekboard.
 
 
 %build
-%configure --disable-static --with-gtk=3.0 --enable-atspi
+%configure --disable-static --enable-atspi
 make %{?_smp_mflags}
 
 
@@ -92,7 +88,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
 
 
 %files -f %{name}.lang
-%defattr(-,root,root,-)
 %doc base-installed/examples
 %{_bindir}/eekboard-server
 %{_bindir}/eekboard
@@ -105,13 +100,11 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
 %{_datadir}/glib-2.0/schemas/*
 
 %files libs
-%defattr(-,root,root,-)
 %doc AUTHORS COPYING README
 %{_libdir}/libeek*.so.*
 %{_libdir}/girepository-1.0/Eek*.typelib
 
 %files devel
-%defattr(-,root,root,-)
 # LGPLv2+
 %{_libdir}/libeek*.so
 %{_includedir}/eek-0.90/
@@ -125,6 +118,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
 
 
 %changelog
+* Fri Apr 13 2012 Daiki Ueno <dueno at redhat.com> - 1.0.7-1
+- new upstream release
+- drop unnecessary %%defattr(-,root,root,-) from %%files
+
 * Sat Mar 31 2012 Daiki Ueno <dueno at redhat.com> - 1.0.6-2
 - Add provides/obsoletes for -python subpackage (fixes #808634)
 
diff --git a/sources b/sources
index c4c8092..9899bee 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-df51180b31a398a7980bdb633138ab9e  eekboard-1.0.6.tar.gz
+905baf1e5f49fbdfd7ddce898927c821  eekboard-1.0.7.tar.gz


More information about the i18n-bugs mailing list