Freeze break request: add branched f17 to

Marko Myllynen myllynen at
Wed Mar 7 12:31:48 UTC 2012


>>>> yum install git make gcc perl syslinux genisoimage
>>>> git clone git:// ipxe.git
>>>> cd ipxe.git/src
>>>> make EMBEDDED_IMAGE=bfo.gpxe bin/ipxe.iso
>>>> make EMBEDDED_IMAGE=bfo.gpxe bin/ipxe.usb
>>>> make EMBEDDED_IMAGE=bfo.gpxe bin/ipxe.dsk
>>>> make EMBEDDED_IMAGE=bfo.gpxe bin/ipxe.lkrn
>>> I tried this and got:
>>> make: *** No rule to make target `bin/ipxe.iso'.  Stop.
>>> basically it doesn't seem they understand a EMBEDDED_IMAGE option.
>> well, forgive me asking, but are you sure you were in the right
>> directory when you tried to build?-)
> I hope so. I was in my ipxe.git/src/ dir.
>> FOO=bar defines a variable FOO for the build and the error you got
>> was about the missing definition of the actual target, bin/ipxe.iso.
> Right. What I get is:
> ...bunch of compile...

Ok, now you're running make in the correct directory, however ...

>    [BUILD] bin/segment.o
> make: *** No rule to make target `bfo.gpxe', needed by
> `bin/embedded.o'.  Stop.

... this means that the embedded script was not found.

As mentioned the script contents and path need to be adjusted for what's 
appropriate for bfo. The reason I didn't say anything explicitly is that 
there seems to be conflicting information in the files README vs 
FEDORA-INFRA in fedora-infrastructure.git.

After a bit of investigation it seems that README corresponds to current 
situation while FEDORA-INFRA does not.

Perhaps we could continue to discussion about these details off-list or 
on IRC as needed?


Marko Myllynen

More information about the infrastructure mailing list