state of the askbot

Ankur Sinha sanjay.ankur at
Mon Jan 13 11:46:37 UTC 2014

On Sun, 2014-01-12 at 12:16 -0700, Kevin Fenzi wrote:
> Greetings. 

Hi Kevin,

> I thought I would write up an email where we stand with
> and things we need to get done and things I would
> like to see. ;)

Thanks for taking the time to compile this list :)

> Staging: 
> - Thanks to anshprat and echevemaster we got a askbot-0.7.49 rpm put
>   together. 
> - We got our old staging all working with it.
> - However, being the paranoid sort and seeing that we had a bunch of
>   people poking at it locally and doing all kinds of things to it, I
>   decided to do a clean staging instance to make sure it would work as
>   expected. 
> - I migrated ask01.stg over to ansible and destroyed the old instance
>   and made a new one with 0.7.49 and the config/etc we had in puppet. 
> - I had to tweak some more things to get it up and going. 
> - It's now up, but it tracebacks in trying to add new questions (at
>   least). 

Aye. I noticed this the other day too. I tried to log in as root to read
the server logs but it said I didn't have sudo access ('ankursinha' is
not in sudoers file). Could you please check if I have the required
permissions on ask01.stg?

> - I didn't do anything to the database, it's the same one we were using
>   for staging before. 
> So, what we need here is to figure out whats wrong with it now and get
> it working, or possibly wipe the db and put the production one over
> there (downside there is that it might send emails, which would confuse
> users, so we need to make sure that doesn't happen if we go that
> route). 

There's a cron job that sends out mail using the post-office backend. We
could just disable that?

> Once we have it all working. I will wipe and make a fresh instance of
> it. I want it to come up working from whats in ansible before we touch
> production. 

The last time I mucked around with it was when we still ran puppet. I
guess I'll have to read up the ansible docs.

> Production / misc: 
> - feedback link is broken, so people send feedback to
>   admin at This is not great as I don't have time/know
>   about specific things some people ask.. Where should we point these?
>   sysadmin-ask-members at

I could at least enter and send feedback on staging. I have no idea who
it went to: I haven't received an e-mail yet. It's possible feedback was
fixed in 0.7.49 too?

> - I have no idea who all is still active in wanting to work on askbot.
>   We should figure that out. Perhaps we could cull the sysadmin-ask
>   group down to those people who are still around and are willing to
>   work on it?

I am. I hadn't the time to do the update with the django1.4 requirement
etc., but since Anshu took care of that I should be able to help with
the other issues.

> - Fedora theme: Ryan was working on that a whlile back. It would sure
>   be nice to get something out there, even if it's not perfect. 

The issue with the theme is that it's slightly tedious to do. One can't
do it locally. One has to log in to ask01 etc. Since the change was
local, and not a hotfix, I'm guessing we've sort of lost whatever
progress was made on this too :(

Whoever wants to work on this will probably be better off setting up a
local instance of askbot, making changes there and then applying them to
our instances as a hotfix.

Here's a quick way of setting askbot up on openshift:

I'm just giving it a whirl to see if it works.

> - It would also be nice to have some way to communicate/collaborate
>   with moderators/admins. Sometimes people ask for karma changes or
>   voting changes or whatever, and it would be nice to have a place to
>   discuss that. I guess meta on the site itself might work, but we
>   should decide. 

+1 for meta on the site. It's a lot better than sending out mails to a
bunch of people. 

> - multilang support. The new 0.7.49 has multilang support, but it
>   wasn't working last we tried it. We should really try and get this
>   working. There are already communities with their own ask instances
>   that could be using the main Fedora one. ;) 

This would be a lot easier if upstream demonstrated multilang support on
their instance (Do they?). It's all documented, but not very easy to

> - The rawhide/Fedora version is still on 0.7.48. There's at least one
>   issue with python-celery and django-celery needing to sync up, but it
>   still needs someone interested in watching that and updating it and
>   testing it, etc. We should make sure it works in Fedora. :) 

We aren't using celery on our instance, are we? We use
django-post-office as the mail backend instead. I'm not sure if celery
is limited to mailing, or if it has other effects on the functioning of
askbot too. It's listed as "optional". Ticket where I set up

It seems django-celery is obsolete and python-celery can work directly
with django from version 3.1

So, it appears that python-celery needs to be updated to 3.1 and
django-celery obsoleted?

> - Theres 8 open ask infrastructure tickets: 
> #3654	Ask Fedora uses flags to show a user's location
> (needs working with upstream to enable disabling them)

Upstream still hasn't set up a config option for this from what I can
see. We'll probably have to take the ugly way out and comment the
related code if we absolutely must.

> #4012 'give feedback' broken
> #3818	Enable multilingual support in ask
> ( hopefully fixed with upgrade )


> #3840	[HOTFIX] Adding upstream fix to post-office to re-enable
> html mailing
> (needs someone to make sure this went upstream, if it's in 0.7.49, etc)

This was a hotfix to django-post_office and not askbot. The hotfix was
provided by upstream itself. There've been releases since it was merged
upstream and I've updated the Fedora packages just today. I'll have to
read the EL update policy etc. to see if I can update the packages there
too. We could use the latest version from the infra repo and get rid of
the hotfix.

> #3884	Apply Fedora theme to Ask Fedora
> #3528	Banner for new user points to FAQ but doesn't provide link
> (needs the theme to exist)
> #3919	Disable login

I think this has been removed already. I don't see the login option in
the staging instance any more. I haven't been able to check if "share to
identica" is still around though. I'll do that once we've gotten the
staging instance working properly.

> #3675	Unable to re-tag posts on Ask Fedora
> (needs working with upstream/making hotfixes)

According to upstream this issue was fixed in 0.7.48. Means it needs
more digging into..

Thanks again for bringing up the list. I'll try and work on some of
these issues in the coming weeks.
Warm regards,
Ankur (FranciscoD)

Join Fedora! Come talk to us!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the infrastructure mailing list