USB installation of Fedora-17

Gilboa Davara gilboad at
Thu Jun 7 12:34:46 UTC 2012

On Tue, Jun 5, 2012 at 3:03 PM, Timothy Murphy <gayleard at> wrote:
> Gilboa Davara wrote:
>>>>> I started by dd-ing the DVD iso onto the single partition /dev/sdb1
>>>>> on the stick.
>>>>> For some reason this did not boot,
>>>>> so I deleted the partition (with fdisk)
>>>>> and dd-ed the iso onto /dev/sdb .
>>>>> Maybe that was my error?
>>> Just to be clear.
>>> When I removed /dev/sdb1 (with fdisk) on the USB stick,
>>> and dd-ed to /dev/sdb exactly as you suggest,
>>> the laptop did boot and I was able to install on my laptop
>>> but the resulting system had only half-a-dozen modules installed
>>> (according to lsmod).
>>> I'm pretty sure the failure had something to do with grub2.
>>> I chose the custom layout, incidentally,
>>> as I wanted to keep Fedora-16 on another partition.
>> I think I know what happened.
>> Are you sharing boot between F16 and F17 by any chance [1]?
> I am.
> I chose custom layout, and gave /dev/sda2 as /boot,
> without formatting it.
> Basically, I hoped that this would allow me to run Fedora-16
> (which I kept on a different partition)
> as an alternative to Fedora-17.
> In fact, when I installed Fedora-17 with netinstall
> everything worked fine, and I can boot into F-16 or F-17 or Windows,
> as hoped.
> What exactly was my error with the USB stick method?
> As I mentioned I had the same problem with the DVD iso
> and with the KDE Live CD (both transferred to the USB stick).

F17's  anaconda installer (or actually, the grub configuration
builders) barfs on having the same kernel version on both F16 and F17,
causing it to select the wrong kernel for F17 (3.3.7-1.fc16.x86_64).
This in-order causes Fedora to oops during either startup or shutdown.
In my cases, I encountered this bug on 10/11 machines I installed
Fedora on (either new install w/ shared boot or [pre-]upgrade).
I solved this problem by forcing grub to load the correct kernel
during first-boot [1]. Once up, I rebuilt the grub configuration [2].

- Gilboa
[1]  Space to get the grub menu, 'e' to edit the grub entry, replace
f16 w/ f17 across the board, Ctrl-X to boot.
[2] grub2-mkconfig -o /boot/grub2/grub.cfg.

More information about the kde mailing list