USB installation of Fedora-17

Patrick O'Callaghan pocallaghan at
Sun Jun 10 14:10:33 UTC 2012

On Sat, 2012-06-09 at 13:11 +0100, Timothy Murphy wrote:
> Gilboa Davara wrote:
> >>> I think I know what happened.
> >>> Are you sharing boot between F16 and F17 by any chance [1]?
> >>
> >> I am.
> >> I chose custom layout, and gave /dev/sda2 as /boot,
> >> without formatting it.
> >>
> >> Basically, I hoped that this would allow me to run Fedora-16
> >> (which I kept on a different partition)
> >> as an alternative to Fedora-17.
> >>
> >> In fact, when I installed Fedora-17 with netinstall
> >> everything worked fine, and I can boot into F-16 or F-17 or Windows,
> >> as hoped.
> >>
> >> What exactly was my error with the USB stick method?
> >> As I mentioned I had the same problem with the DVD iso
> >> and with the KDE Live CD (both transferred to the USB stick).
> > 
> > F17's  anaconda installer (or actually, the grub configuration
> > builders) barfs on having the same kernel version on both F16 and F17,
> > causing it to select the wrong kernel for F17 (3.3.7-1.fc16.x86_64).
> > This in-order causes Fedora to oops during either startup or shutdown.
> > In my cases, I encountered this bug on 10/11 machines I installed
> > Fedora on (either new install w/ shared boot or [pre-]upgrade).
> > I solved this problem by forcing grub to load the correct kernel
> > during first-boot [1]. Once up, I rebuilt the grub configuration [2].
> Thanks again.
> That certainly sounds like what happened to me,
> as grub seemed seriously confused between F16 and F17.
> I still find grub2 difficult to configure,
> and haven't found an entirely satisfactory HOWTO or similar document.

I had some issues with oopses during shutdown, so after thrashing about
for a while I did the following:

cd /boot
mv grub grub-save
yum reinstall grub2

I conjecture that moving the old grub out of the way may affect how
grub2 installs itself, but for whatever reason it appears to have


More information about the kde mailing list