[Fedora-livecd-list] livecd-creator used to work on centos 5, now giving "syslinux not installed" error

Peter Scheie peter.scheie at visionshareinc.com
Tue Sep 1 18:54:23 UTC 2009


A couple weeks ago I used the instructions at
https://projects.centos.org/trac/livecd/ to create a live CD of CentOS
5.  I did this on a Centos 5.3 virtual machine running under VirtualBox
running on top of Ubuntu, at my office.  I did the same thing at home on
my laptop.  In both cases I was able to create the minimal livecd and
the full destkop livecd.  Then I went on vacation for three weeks.  When
I got back, I tried to create another livecd image, using the same
command, to just refresh my memory of what I'd been working on.  Here's
the command I used:

LANG=C livecd-creator --config=centos-livecd-minimal.ks
--fslabel=CentOS-minimal

But this time, I got the following error:

Error creating Live CD : syslinux not installed : no suitable *menu.c32
found

I tried it at home as well and got the same error.  I've got syslinux
3.36-4.2 installed, including menu.c32 and vesamenu.c32.  Any ideas as
to what would have changed that would cause livecd-creator to break, or
how to fix it?  Thanks.

Peter




More information about the livecd mailing list