[Fedora-livecd-list] selinux set to permissive in kickstart, but ISO says it's in enforcing mode

Patrice Guay patrice.guay at nanotechnologies.qc.ca
Tue Sep 1 21:02:46 UTC 2009

Peter Scheie wrote:
> I'm trying to build a Centos livecd that will mostly call anaconda with
> a kickstart file on an http server.  I modified the
> centos-livecd-minimal.ks file, first adding system-config-network-tui to
> the %packages section to get networking, and the resulting ISO worked
> fine.  Next I added anaconda to the %packages section.  But the
> resulting ISO kernel panics saying "Unable to load SELinux Policy.
> Machine is in enforcing mode."  I don't really need selinux for my
> purposes, so I changed the selinux setting in the ks file to
> --permissive, but I still get the same panic.  Any ideas as to why the
> permissive setting isn't being picked up? Or what about adding anaconda
> (which admittedly adds a bunch of other packages) made it stop loading
> the policy file? Thanks.
> Peter

What is the current SELinux policy on the machine used to build the 
LiveCD? As stated in the CentOS LiveCD documentation, "the build host 
should have SELinux in permissive mode. Edit /etc/sysconfig/selinux and 
restart the computer to enforce this policy."

Patrice Guay

More information about the livecd mailing list