[Bug 799398] SDL_Init not found in libSDL.dll.a

bugzilla at redhat.com bugzilla at redhat.com
Sun Mar 4 00:50:36 UTC 2012

Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.


--- Comment #5 from salsaman <salsaman at gmail.com> 2012-03-03 19:50:35 EST ---
In answer to the questions, I am attempting to compile my own package, which
contains a number of plugins each of which needs to be compiled as a dll. One
of the plugins is called SDL.dll, but has nothing to do with the mingw32

However, attempting to compile a shared lib (dll) against another shared lib
(dll) produces the warning message noted in comment 2, and the output dll is
not created.

(This is with the standard fedora 16 libtool).

As a workaround, I read somewhere that one can force static linking with the
dependencies by doing -Wl,<path_to_static_lib>. In fact this has worked
succesfully with other plugins. Therefore I was attempting to do the same with
my SDL.dll

It seems I am also misunderstanding something - I was assuming that libSDL.dll
was the equivalent of a shared lib, and libSDL.dll.a was the equivalent of a
static lib. I am not sure what is meant by "import library".

Finally regarding the rpath, I am not sure where this comes from, I think it
comes from the installation directory in Makefile.am. I tried removing this but
then it was impossible to run automake, so I have been forced to leave it in.

Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

More information about the mingw mailing list