rawhide-xo 20090312 daily build n00b observations

S Page skierpage at gmail.com
Fri Mar 13 13:30:10 UTC 2009

With help from most excellent cjb I got the revised
20090312.bootable.gz on an 8GB SD card and it booted on my XO running
candidate 801 and recent firmware.

I created http://wiki.laptop.org/go/Rawhide-XO and its Talk page,
seems useful.  Maybe http://wiki.laptop.org/go/Rawhide-XO can link to
it; maybe the info belongs on SugarLabs.org ?

I was able to use `zcat 20090312.bootable.gz  > /dev/sdb` in Windows
XP SP3 under Cygwin.  In case anyone else is stupid enough to use
* I used `cat /proc/partitions` to figure out what device it was.
* Twice I had a corrupted FAT32 root directory.  I suspect Windows got
confused about the altered partitioning.  I wound up running Cygwin's
`sync` after zcat and then yanking the card out, *not* using Windows
"Safely Remove Hardware".

==> One obvious downside of this zcat approach is it writes its own
partition table, so AIUI until you fiddle with a partition editor, the
rest of your flash drive is unusable.  It would be nice and work
better in Windows if Rawhide-XO could use the
https://fedorahosted.org/liveusb-creator/ that SoaS recommends.

==> I'm clueless on LiveCDs/Live USBs, is there a user's guide to them
that explains simple things like does its content get updated, how to
mount my XO's NAND flash, what /dev/dm-1 on /media/20090312 is in the
mount table, is there still Ctrl+Alt+F3 to get a console, etc.

== Booting and login ==

During boot:
  IO APIC resource could not be allocated
  Unable to find persistent overlay: using temporary X 2
  /bin/mknod: /dev/loop{0..7}: File exists x 8

  Deprecated config file /etc/modprobe.conf + other modprobe warnings

I got a login screen with overlapping garbled text at the lower right.
 It had a chooser for keyboard which defaulted to en_US keyboard.

The first time before I did anything it auto-logged me into a Gnome-ish desktop.
The second time I booted I scrolled through the keyboard list looking
for an English OLPC Keyboard layout , but could not find one, just
Afghanistan OLPC keyboards (yet there is "OLPC" in Gnome Keyboard
preferences).  While looking at this I got auto-logged in again.

== Gnome/X ==
The Gnome desktop: Pretty snappy, not bad!  I've previously only used
Gnome for a few minutes under emulation.

I got an alert "Error activating XKB configuration". Is this the same
as the "1. complained about the keyboard map" that others reported?
Here are the two commands the alert told me to run
$ xprop -root | grep XKB
 _XKB_RULES_NAMES(STRING) = "evdev", "pc105+inet", "us", "", ""

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
  layouts = [en_US.UTF-8]
  options = []
  model =

I used System > Preferences > Keyboard > Layouts to choose OLPC, but
then I got the same alert.  After doing this gconftool-2 thought I had
model = olpc, but _XKB_RULES_NAMES was unchanged.

I got a warning "Battery may be broken"

No power management from power key or lid close.  (Sounds like I
should follow Scott Douglass' HowTo's, but I'm not sure that I can if
running from a live USB.)

The file browser and Places show a LIVE device but nothing happens if
I choose it.

Clicking the web and mail icons gave errors "Could not launch
application  Firefox/evolution" (they're not installed)

== Sugar ==
How do I launch activities in Gnome?  In Terminal I tried
`sugar-activity Pippy` and got SUGAR_BUNDLE_PATH is not defined in the

How do I start the Sugar desktop instead of Gnome?  I guessed and ran
`sugar-session`.  That asked for Name, then "click to change color"
but didn't show any XO guy.

The Sugar Home view appeared with TurtleArt, etc., but it seemed the
top of its menu bar was obscured by the Gnome menu strip across the
No XO guy in the middle, but hovering brought up the XO guy's context menu.

Pressing the Frame key brought up a Gnome-ish context menu, not the Frame.

Moving to a corner  brought up a Frame, but then I couldn't make it go
away.  It seems a lot of icons are missing from the frame.

I started Calc, but it pulsed for a long time before returning to the Home view.

I wound up with five "sugar-session" items in the Gnome bottom menu
strip, it seems one for each part of the Frame.
When I pressed Alt-Tab to return to Gnome's Terminal, I couldn't get
back to a Sugar desktop showing the Home view no matter what items I
clicked or Alt-Tabbed.  Yet `sugar-session` was still running.  I
finally Ctrl-C'd it.

I tried again, immediatley moving Sugar to a different workspace.
That workspace didn't show any icon for Sugar.
The Home and Activity keys worked, but still starting Pippy just
pulsed for a long time then returned to Home view.

Invisible XO guy's My Settings worked, though "Languages" icon was cut
off.  "Generic release 10.92 (Rawhide), Sugar 0.84.0.

== Finish ==

Logout dumped some console output and then returned to a login screen.

I chose [Shutdown], I didn't get the OLPC cautions graphic.

The XO didn't power off, I had to hold down the power button.

Now to repeat all this with the SoaS 2 USB flash drive I just made!

I apologize for the clueless questions, but I will write down what I learn.

=S Page

More information about the olpc mailing list