[SECURITY] Fedora 15 Update: rubygem-railties-3.0.5-1.fc15

updates at fedoraproject.org updates at fedoraproject.org
Tue Apr 5 21:43:09 UTC 2011

Fedora Update Notification
2011-03-30 02:21:01

Name        : rubygem-railties
Product     : Fedora 15
Version     : 3.0.5
Release     : 1.fc15
URL         : http://www.rubyonrails.org
Summary     : Tools for creating, working with, and running Rails applications
Description :
Rails internals: application bootup, plugins, generators, and rake tasks.
Railties is responsible to glue all frameworks together. Overall, it:
* handles all the bootstrapping process for a Rails application;
* manager rails command line interface;
* provides Rails generators core;

Update Information:

Update to the Rails 3.0.5

  [ 1 ] Bug #679351 - CVE-2011-0449 rubygem-actionpack: Intended access restriction bypass via crafted action name, when case-insensitive filesystem is used
  [ 2 ] Bug #679343 - CVE-2011-0448 rubygem-activerecord: SQL injection attacks via a non-numeric arguments
  [ 3 ] Bug #677631 - CVE-2011-0447 rubygem-actionpack: CSRF flaws due improper validation of HTTP headers containing X-Requested-With header
  [ 4 ] Bug #677626 - CVE-2011-0446 rubygem-actionpack: Multiple XSS flaws via crafted name or email value in the mail_to_helper

This update can be installed with the "yum" update program.  Use 
su -c 'yum update rubygem-railties' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at

More information about the package-announce mailing list