Fedora 15 Update: libproxy-0.4.7-1.fc15

updates at fedoraproject.org updates at fedoraproject.org
Sat Jun 25 20:00:18 UTC 2011


--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2011-8197
2011-06-11 03:55:55
--------------------------------------------------------------------------------

Name        : libproxy
Product     : Fedora 15
Version     : 0.4.7
Release     : 1.fc15
URL         : http://code.google.com/p/libproxy/
Summary     : A library handling all the details of proxy configuration
Description :
libproxy offers the following features:

    * extremely small core footprint (< 35K)
    * no external dependencies within libproxy core
      (libproxy plugins may have dependencies)
    * only 3 functions in the stable external API
    * dynamic adjustment to changing network topology
    * a standard way of dealing with proxy settings across all scenarios
    * a sublime sense of joy and accomplishment

--------------------------------------------------------------------------------
Update Information:


- Update to 0.4.7 svn20110412
- Add support for webkitgtk3
- Add support for xulrunner 2.0
- fix #683015 - libproxy fails with autoconfiguration
- fix #683018 - libproxy needs BR: NetworkManager-glib-devel  (f14)
- Manually fix libproxy-1.0.pc version field - #664781 / #674854
--------------------------------------------------------------------------------
ChangeLog:

* Tue Jun  7 2011 Nicolas Chauvet <kwizart at gmail.com> - 0.4.7-1
- Update to 0.4.7
- libproxy-1.0.pc is now reliable starting with 0.4.7
* Tue Apr 12 2011 Nicolas Chauvet <kwizart at gmail.com> - 0.4.7-0.1svn20110412
- Update to 0.4.7 svn20110412
- Add support for webkitgtk3
- Add support for xulrunner 2.0
- fix #683015 - libproxy fails with autoconfiguration
- fix #683018 - libproxy needs BR: NetworkManager-glib-devel  (f14)
- Manually fix libproxy-1.0.pc version field - #664781 / #674854
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #673077 - libproxy misbehaves
        https://bugzilla.redhat.com/show_bug.cgi?id=673077
  [ 2 ] Bug #683015 - libproxy fails with autoconfiguration "http://proxy.domain.com"
        https://bugzilla.redhat.com/show_bug.cgi?id=683015
  [ 3 ] Bug #683018 - libproxy needs BuildRequires:  NetworkManager-glib-devel
        https://bugzilla.redhat.com/show_bug.cgi?id=683018
  [ 4 ] Bug #664781 - libproxy-devel has wrong pkg config
        https://bugzilla.redhat.com/show_bug.cgi?id=664781
  [ 5 ] Bug #674854 - pkg-config libproxy-1.0 --modversion output empty
        https://bugzilla.redhat.com/show_bug.cgi?id=674854
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update libproxy' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------


More information about the package-announce mailing list