Fedora 15 Update: libqb-0.6.0-2.fc15

updates at fedoraproject.org updates at fedoraproject.org
Fri Sep 16 02:00:26 UTC 2011


--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2011-12229
2011-09-07 04:07:34
--------------------------------------------------------------------------------

Name        : libqb
Product     : Fedora 15
Version     : 0.6.0
Release     : 2.fc15
URL         : http://www.libqb.org
Summary     : An IPC library for high performance servers
Description :
libqb provides high performance client server reusable features.
Initially these are IPC and poll.

--------------------------------------------------------------------------------
Update Information:

update libqb to upstream 0.6.0
--------------------------------------------------------------------------------
ChangeLog:

* Thu Sep  1 2011 Angus Salkeld <asalkeld at redhat.com> - 0.6.0-2
- LOG: fix the default syslog filter
* Tue Aug 30 2011 Angus Salkeld <asalkeld at redhat.com> - 0.6.0-1
- Rebased to 0.6.0 which includes (#734457):
- Add a stop watch
- LOG: serialize the va_list, don't snprintf
- LOG: change active list into array access
- atomic: fix qb_atomic_pointer macros
- LOG: allow the thread priority to be set.
- Fix splint warning on ubuntu 11.04
* Mon Jul 18 2011 Angus Salkeld <asalkeld at redhat.com> - 0.5.1-1
- Rebased to 0.5.1 which includes:
- LOOP: make the return more consistent in qb_loop_timer_expire_time_get()
- LOG: add string.h to qblog.h
- Add a qb_strerror_r wrapper.
- don't let an invalid time stamp provoke a NULL dereference
- LOG: move priority check up to prevent unnecessary format.
- rename README to README.markdown
* Wed Jun  8 2011 Angus Salkeld <asalkeld at redhat.com> - 0.5.0-1
- Rebased to 0.5.0 which includes:
- new logging API
- support for sparc
- coverity fixes
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #736209 - update libqb to upstream 0.6.0 (-2)
        https://bugzilla.redhat.com/show_bug.cgi?id=736209
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update libqb' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------


More information about the package-announce mailing list