Fedora 20 Update: rubygem-narray-0.6.0.8-9.fc20

updates at fedoraproject.org updates at fedoraproject.org
Sun Dec 22 05:39:44 UTC 2013


--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2013-23325
2013-12-13 17:39:32
--------------------------------------------------------------------------------

Name        : rubygem-narray
Product     : Fedora 20
Version     : 0.6.0.8
Release     : 9.fc20
URL         : http://narray.rubyforge.org
Summary     : N-dimensional Numerical Array class for Ruby
Description :
NArray is a Numerical N-dimensional Array class.  Supported element types are
1/2/4-byte Integer, single/double-precision, Real/Complex and Ruby Object.
This extension library incorporates fast calculation and easy manipulation of
large numerical arrays into the Ruby language.  NArray has features similar to
NumPy, but NArray has vector and matrix sub-classes.

--------------------------------------------------------------------------------
Update Information:

fixed the way ruby(abi) is required - dropped the symlinks in %{ruby_vendorarchdir}, except for <= el6 - fixed directory ownerships on <= el6 - use BuildRequires: rubygems-devel on el6, too
several improvements for RHEL <= 6 and added needed bits for RHEL <= 5\nadded needed Provides
adapted Requires: ruby(abi) = 1.9.1 for Fedora 18, only
fixed symlinks in %{ruby_vendorarchdir}
--------------------------------------------------------------------------------
ChangeLog:

* Fri Dec 13 2013 Björn Esser <bjoern.esser at gmail.com> - 0.6.0.8-9
- fixed the way ruby(abi) is required
- dropped the symlinks in %{ruby_vendorarchdir}, except for <= el6
- fixed directory ownerships on <= el6
- use BuildRequires: rubygems-devel on el6, too
* Tue Dec 10 2013 Björn Esser <bjoern.esser at gmail.com> - 0.6.0.8-8
- fixed symlinks in %{ruby_vendorarchdir}
* Tue Dec 10 2013 Björn Esser <bjoern.esser at gmail.com> - 0.6.0.8-7
- adapted Requires: ruby(abi) = 1.9.1 for Fedora 18, only
* Tue Dec 10 2013 Björn Esser <bjoern.esser at gmail.com> - 0.6.0.8-6
- several improvements for RHEL <= 6 and added needed bits for RHEL <= 5
- added needed Provides
* Mon Nov 25 2013 Björn Esser <bjoern.esser at gmail.com> - 0.6.0.8-5
- Fedora <= 18 && RHEL <= 6 need Requires: ruby(abi)
* Mon Nov 25 2013 Björn Esser <bjoern.esser at gmail.com> - 0.6.0.8-4
- added conditional for Requires: ruby(release) or ruby(abi) on older dists
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #1040936 - rubygem-narray has dependency for invalid version of ryby(abi)
        https://bugzilla.redhat.com/show_bug.cgi?id=1040936
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update rubygem-narray' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------


More information about the package-announce mailing list