Fedora 18 Update: php-bartlett-PHP-Reflect-1.5.0-1.fc18

updates at fedoraproject.org updates at fedoraproject.org
Fri Jan 11 23:26:31 UTC 2013


--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2012-21102
2012-12-30 20:06:53
--------------------------------------------------------------------------------

Name        : php-bartlett-PHP-Reflect
Product     : Fedora 18
Version     : 1.5.0
Release     : 1.fc18
URL         : http://bartlett.laurent-laville.org/
Summary     : Adds the ability to reverse-engineer PHP
Description :
PHP_Reflect adds the ability to reverse-engineer classes, interfaces,
functions, constants and more, by connecting php callbacks to other tokens.


HTML Documentation:  %{pear_docdir}/PHP_Reflect/docs/index.html

--------------------------------------------------------------------------------
Update Information:

PHP_Reflect 1.5.0:
* add new method isNamespaceWarning() that allow to know if PHP platform is PHP 5.2 and source code scanned included namespace syntax
* refactoring the documentation build phing script (split generic and specific code)

PHP_CompatInfo 2.11.0 (2012-12-21)

Additions and changes:
* upgrade mongo reference to version 1.3.2
* upgrade memcache reference to version 3.0.7
* fix amqp reference (thanks to Remi Collet)
* fix memcached reference (thanks to Remi Collet)
* fix memcache reference (thanks to Remi Collet)
* fix imagick reference (thanks to Remi Collet)
* interfaces ArrayAcess, Iterator, IteratorAggregate, Serializable, Traversable were moved form SPL to Core since PHP 5.3.0
* SimpleXMLIterator was moved from SPL (PHP 5.2) to SimpleXml (PHP 5.3)
* give always a readable version (whatever process used to install the CLI version)

Bug fixes:
* GH-54 : Cannot generate documentation with missing UML diagrams pictures
* GH-55 : support multiple -d directive

Version 2.10.0 (2012-11-26)

Additions and changes:
* add 3 new references data dictionnaries related to extensions: igbinary, imagick, odbc
* add clear-cache sub-command to CLI version
* upgrade amqp reference to version 1.0.9
* upgrade xcache reference to version 3.0.0
* used temporary system directory rather than /tmp that does not exists by default on windows
* refactoring the documentation build phing script (split generic and specific code)
* PHP min is set (at least) to 5.3.0 when you use namespace syntax on PHP 5.2 platform (requires PHP_Reflect 1.5.0 or greater)

Bug fixes:
* GH-51 fix --report-file option with file in current path directory
* PHP Doc bug 60638 standard reference fixed: parse_url component parameter is provided since PHP 5.1.2 and not 5.2.0


Version 2.9.0 (2012-10-29)

Additions and changes:
* all required resources used now the default autoloader
* allow to run either a stand-alone or pear installed version
* Reports refactoring (33 percent code reduced)
* Source, Database and Reference reports will not be print anymore on standard output when --report-file option used
* CAUTION: BC breaks with API 2.8.0 with the new filter system
* list-references does not require --reference option anymore (always used ALL)
* results of list-references may now be filtered
* add a full report (all results at once: summary, extensions, interfaces, traits, classes, functions, constants, globals, tokens, conditions)
* fixed Reference interface about new filter API
*  WARNING: PHP_Timer 1.0.4 (autoloader) break PHP 5.2 compatibility, so the print resource feature become optional
* improved true results again with detection of conditional code and excludes from parsing
* upgrade ssh reference to version 0.12 (thanks to Remi Collet)
* upgrade openssl reference with new PHP 5.4.8 constants (thanks to Remi Collet)
* upgrade standard reference with PHP 5.4.8 optional second argument for assert() to specify custom message
* Extension report show now the real extension version min/max depending of others elements parsed (thanks to Remi Collet to noticed me)
* test suites may be run by group, using phpunit --exclude-group or --group switches

Bug fixes:
* PHP 5.4 raises notice error (Array to string conversion) in file cache, while PHP 5.2 and 5.3 did not
* standard reference fixed: mkdir mode parameter is required since PHP 4.0.0 and not 4.2.0 (it became optional)
* multiple reports may now be appended in the same report file
* fixed phpunit-growl.xml configuration file: display icons to both pear or stand-alone installation
* avoid php warnings when argument to list command (of CLI tool) is invalid (requires Console_CommandLine 1.2.0 or better)
* depending of typeHint (interface, class), report now in the real category rather than just in classes

--------------------------------------------------------------------------------
ChangeLog:

* Sun Dec 30 2012 Remi Collet <remi at fedoraproject.org> - 1.5.0-1
- Version 1.5.0 (stable) - API 1.5.0 (stable)
- generate documentation using asciidoc, without phing
* Tue Oct 30 2012 Remi Collet <remi at fedoraproject.org> - 1.4.3-1
- Version 1.4.3 (stable) - API 1.4.0 (stable)
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update php-bartlett-PHP-Reflect' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------


More information about the package-announce mailing list