Fedora 18 Update: ocaml-ancient-0.9.0-10.fc18

updates at fedoraproject.org updates at fedoraproject.org
Sat Jan 12 00:55:39 UTC 2013


--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2012-20337
2012-12-14 06:37:20
--------------------------------------------------------------------------------

Name        : ocaml-ancient
Product     : Fedora 18
Version     : 0.9.0
Release     : 10.fc18
URL         : http://merjis.com/developers/ancient
Summary     : OCaml library for large memory structures and sharing
Description :
Ancient is an OCaml module that allows you to use in-memory data
structures which are larger than available memory and so are kept in
swap. If you try this in normal OCaml code, you'll find that the
machine quickly descends into thrashing as the garbage collector
repeatedly iterates over swapped memory structures. This module lets
you break that limitation. Of course the module doesn't work by magic.
If your program tries to access these large structures, they still
need to be swapped back in, but it is suitable for large, sparsely
accessed structures.

Secondly, this module allows you to share those structures between
processes. In this mode, the structures are backed by a disk file, and
any process that has read/write access to that disk file can map that
file in and see the structures.

Developers should read the README.txt file included with the
ocaml-ancient-devel package carefully.

--------------------------------------------------------------------------------
Update Information:

Update OCaml to attempt to fix RHBZ#877128.
--------------------------------------------------------------------------------
ChangeLog:

* Tue Oct 30 2012 Richard W.M. Jones <rjones at redhat.com> - 0.9.0-10
- Rebuild for OCaml 4.00.1.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #877128 - Ocaml tries to allocate a ridiculous amount of memory
        https://bugzilla.redhat.com/show_bug.cgi?id=877128
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update ocaml-ancient' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------


More information about the package-announce mailing list