Fedora 19 Update: lua-moonscript-0.2.4-1.fc19

updates at fedoraproject.org updates at fedoraproject.org
Mon Jul 15 00:54:52 UTC 2013


--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2013-12438
2013-07-05 23:17:09
--------------------------------------------------------------------------------

Name        : lua-moonscript
Product     : Fedora 19
Version     : 0.2.4
Release     : 1.fc19
URL         : http://moonscript.org/
Summary     : A little language that compiles to Lua
Description :
MoonScript is a dynamic scripting language that compiles into Lua. It
gives you the power of Lua combined with a rich set of features.

MoonScript can either be compiled into Lua and run at a later time, or
it can be dynamically compiled and run using the moonloader. It’s as
simple as require "moonscript" in order to have Lua understand how to
load and run any MoonScript file.

Because it compiles right into Lua code, it is completely compatible
with alternative Lua implementations like LuaJIT, and it is also
compatible with all existing Lua code and libraries.

The command line tools also let you run MoonScript directly from the
command line, like any first-class scripting language.

--------------------------------------------------------------------------------
Update Information:

LPeg:
- no "unsigned short" limit for pattern sizes
- mathtime captures considered nullable
- some bugs fixed

Moonscript:
- various updates. Test fixture currently not run, awaiting packaging of new dependencies
--------------------------------------------------------------------------------
ChangeLog:

* Thu Jul  4 2013 Michel Salim <salimma at fedoraproject.org> - 0.2.4-1
- Update to 0.2.4
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #959929 - lua-lpeg-0.12 is available
        https://bugzilla.redhat.com/show_bug.cgi?id=959929
  [ 2 ] Bug #981384 - lua-moonscript-0.2.4 is available
        https://bugzilla.redhat.com/show_bug.cgi?id=981384
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update lua-moonscript' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------


More information about the package-announce mailing list