Fedora 18 Update: abi-compliance-checker-1.99.7-1.fc18

updates at fedoraproject.org updates at fedoraproject.org
Mon Jul 15 01:11:46 UTC 2013


--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2013-12529
2013-07-07 00:05:09
--------------------------------------------------------------------------------

Name        : abi-compliance-checker
Product     : Fedora 18
Version     : 1.99.7
Release     : 1.fc18
URL         : http://ispras.linuxbase.org/index.php/ABI_compliance_checker
Summary     : An ABI Compliance Checker
Description :
A tool for checking backward binary compatibility of a shared C/C++ library. It
checks for changes in calling stack, changes in v-table, removed symbols, etc.

--------------------------------------------------------------------------------
Update Information:

Improvements
* Added missed fields of template instance types to the ABI dump
* Improved support for old ABI dumps
* Added Struct_Field_Size_Increased rule
* Support for vector types (GCC extension)
* Removed duplicates from the ABI dump
* Corrected visualization of v-table content in the report
* Corrected identification of target headers
* Corrected source-compatibility check
* Performance optimization (5%)
New Options
* -check - to check completeness of the ABI dump
Bug Fixes
* Fixed default arguments of methods (broken in 1.99.1 due to added "this" parameter)
Other
* Extended test suite
--------------------------------------------------------------------------------
ChangeLog:

* Sat Jun 29 2013 Richard Shaw <hobbes1069 at gmail.com> - 1.99.7-1
- Update to latest bugfix release.
* Tue Jun 25 2013 Richard Shaw <hobbes1069 at gmail.com> - 1.99.2-1
- Update to latest bugfix release.
* Sat Jun  8 2013 Richard Shaw <hobbes1069 at gmail.com> - 1.99.1-1
- Update to latest bugfix release.
* Tue May 28 2013 Richard Shaw <hobbes1069 at gmail.com> - 1.99-1
- Update to latest upstream release.
* Fri May  3 2013 Richard Shaw <hobbes1069 at gmail.com> - 1.98.8-2
- Add package requires for gcc-c++, ctags, ccache.
* Fri Feb  8 2013 Richard Shaw <hobbes1069 at gmail.com> - 1.98.8-1
- Update to latest upstream release.
* Sat Dec 15 2012 Richard Shaw <hobbes1069 at gmail.com> - 1.98.7-1
- Update to latest upstream release.
* Wed Dec  5 2012 Richard Shaw <hobbes1069 at gmail.com> - 1.98.6-1
- Update to latest upstream release.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #977670 - abi-compliance-checker-1.99.7 is available
        https://bugzilla.redhat.com/show_bug.cgi?id=977670
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update abi-compliance-checker' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------


More information about the package-announce mailing list