Fedora 18 Update: nspr-4.10.0-3.fc18

updates at fedoraproject.org updates at fedoraproject.org
Tue Jul 16 01:28:27 UTC 2013


--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2013-12367
2013-07-05 00:35:34
--------------------------------------------------------------------------------

Name        : nspr
Product     : Fedora 18
Version     : 4.10.0
Release     : 3.fc18
URL         : http://www.mozilla.org/projects/nspr/
Summary     : Netscape Portable Runtime
Description :
NSPR provides platform independence for non-GUI operating system
facilities. These facilities include threads, thread synchronization,
normal file and network I/O, interval timing and calendar time, basic
memory management (malloc and free) and shared library linking.

--------------------------------------------------------------------------------
Update Information:

This update fixes a problem where the xulrunner required version of nspr could not be found. (Bug 981166)

pkg-config reads the config/nspr.pc file which has the line:

Version: @MOD_MAJOR_VERSION at .@MOD_MINOR_VERSION at .@MOD_PATCH_VERSION@

The pkg-config reptorted version always includes the "patch" version number, even if it's zero.

Because the build automation uses rules based on the reported version number, the system package versions follow the versions shown in the tar archive. Because the tar archive excluded the patch version, that resulted in a package version without the patch version, which resulted in an unsatisfied lookup as the software looks for the version reported by pkg-config. In this case, because nspr-4.10 < nspr.4.10.0, dependency resolution failed.

The patch version number is now included in the package version number. 
--------------------------------------------------------------------------------
ChangeLog:

* Thu Jun 27 2013 Elio Maldonado <emaldona at redhat.com> - 4.10.0-3
- Repackage the source tar ball as nspr-4.10.0.tar.bz2
- Ensure client packages dependency resolution succeeds
- Resolves: rhbz#981166 - xulrunner requires an wrong version of nspr
* Tue Jun 18 2013 Elio Maldonado <emaldona at redhat.com> - 4.10-2
- Install man page for the nspr-config script
* Wed May 29 2013 Elio Maldonado <emaldona at redhat.com> - 4.10-1
- Update to NSPR_4_10_RTM
* Mon May  6 2013 Elio Maldonado <emaldona at redhat.com> - 4.9.6-1
- Update to NSPR_4_9_6_RTM
* Mon Feb 18 2013 Elio Maldonado <emaldona at redhat.com> - 4.9.5-2
- Resolves: rhbz#912483 - Add spec file support for AArch64
* Fri Feb  1 2013 Elio Maldonado <emaldona at redhat.com> - 4.9.5-1
- Update to NSPR_4_9_5_RTM
* Mon Dec 17 2012 Elio Maldonado <emaldona at redhat.com> - 4.9.4-1
- Update to NSPR_4_9_4_RTM
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #981166 - The xulrunner required version of nspr cannot be found
        https://bugzilla.redhat.com/show_bug.cgi?id=981166
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update nspr' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------


More information about the package-announce mailing list