Fedora 22 Update: php-phpunit-PHP-CodeCoverage-2.0.16-1.fc22

updates at fedoraproject.org updates at fedoraproject.org
Tue Apr 21 19:14:40 UTC 2015


--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2015-5174
2015-03-31 17:08:24
--------------------------------------------------------------------------------

Name        : php-phpunit-PHP-CodeCoverage
Product     : Fedora 22
Version     : 2.0.16
Release     : 1.fc22
URL         : https://github.com/sebastianbergmann/php-code-coverage
Summary     : PHP code coverage information
Description :
Library that provides collection, processing, and rendering functionality
for PHP code coverage information.

--------------------------------------------------------------------------------
Update Information:

**PHPUnit 4.6**
* See https://github.com/sebastianbergmann/phpunit/wiki/Release-Announcement-for-PHPUnit-4.6.0

**sebastian/diff 1.3.0**

**sebastian/environment 1.2.2**

**phpunit/php-file-iterator 1.4.0**
* Added support for wildcards (glob) in exclude

**sebastian/version 1.0.5**

**sebastian/git 2.0.1**

**phploc/phploc 2.1.1**

**phpunit/php-code-coverage 2.0.16**

**phpunit/dbunit 1.3.2**
* Added the ArrayDataSet as mentioned in the documentation.

** prophecy 1.4.0**
* Fixed errors in return type phpdocs (thanks @sobit)
* Fixed stringifying of hash containing one value (thanks @avant1)
* Improved clarity of method call expectation exception (thanks @dantleech)
* Add ability to specify which argument is returned in willReturnArgument (thanks @coderbyheart)
* Add more information to MethodNotFound exceptions (thanks @ciaranmcnulty)
* Support for mocking classes with methods that return references (thanks @edsonmedina)
* Improved object comparison (thanks @whatthejeff)
* Adopted '^' in composer dependencies (thanks @GrahamCampbell)
* Fixed non-typehinted arguments being treated as optional (thanks @whatthejeff)
* Magic methods are now filtered for keywords (thanks @seagoj)
* More readable errors for failure when expecting single calls (thanks @dantleech)


--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use
su -c 'yum update php-phpunit-PHP-CodeCoverage' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------


More information about the package-announce mailing list