[Bug 226003] Merge Review: libexif

bugzilla at redhat.com bugzilla at redhat.com
Sun Feb 4 19:30:46 UTC 2007


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: Merge Review: libexif


https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=226003


roozbeh at farsiweb.info changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         AssignedTo|roozbeh at farsiweb.info       |mclasen at redhat.com
                 CC|                            |roozbeh at farsiweb.info
               Flag|fedora-review?              |fedora-review-




------- Additional Comments From roozbeh at farsiweb.info  2007-02-04 14:30 EST -------
First issues and suggestions, in random order:

* Several patch files in CVS are not used. Please remove.
* change BuildRoot to %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
* The resolved URL for Source0
(http://umn.dl.sourceforge.net/sourceforge/libexif/lixexif-0.6.13.tar.bz2) gives
me a 404 HTTP error.
* The AUTHORS files shipped in the RPM is empty.
* Change the Requires line of -devel to %{name} = %{version}-%{release}
* Devel package description says that there are also static packages. There are not.
* Don't use %makeinstall. Use make DESTDIR=$RPM_BUILD_ROOT install.
* Documents are installed into two different directories, /usr/share/doc/libexif
(in libexif-devel) and /usr/share/doc/libexif-%{version} (in libexif). Make them
one.
* Make -devel require pkgconfig, as it includes *.pc files.


-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.




More information about the package-review mailing list