fedora-review denied: [Bug 226298] Merge Review: pirut

bugzilla at redhat.com bugzilla at redhat.com
Fri Feb 9 21:42:17 UTC 2007


Bug 226298: Merge Review: pirut
Product: Fedora Extras
Version: devel
Component: Package Review

Jima <jima at beer.tclug.org> has denied Jima <jima at beer.tclug.org>'s request for
fedora-review:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=226298

------- Additional Comments from Jima <jima at beer.tclug.org>
OK - Spec in American English
OK - Spec is legible.
See below - Sources match upstream md5sum:
a8f5de528d0491ccbaed671063200521  pirut-1.2.10.tar.gz
OK - BuildRequires correct
OK - Package has %defattr and permissions on files is good.
OK - Package has a correct %clean section.
See below - Package has correct buildroot
OK - Package is code or permissible content.
OK - Packages %doc files don't affect runtime.
OK - Package compiles and builds on at least one arch.
OK - Package has no duplicate files in %files.
OK - Package doesn't own any directories other packages own.
OK - Package owns all the directories it creates.
See below - No rpmlint output.
See below - final provides and requires are sane:

SHOULD Items:

OK - Should build in mock.
OK - Should build on all supported archs
OK - Should function as described.
OK - Should have dist tag
OK - Should package latest version
62 bugs - check for outstanding bugs on package.

1. Ha ha ha

No upstream site, no MD5SUM to authenticate against, no place to check
we have the latest version.  We should probably do something about that.
:-)

2. The recommended BuildRoot is:

%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

3. rpmlint says:

on pirut-1.2.10-1.fc7.noarch.rpm:
E: pirut obsolete-not-provided system-config-packages
E: pirut obsolete-not-provided redhat-config-packages
E: pirut obsolete-not-provided pup
E: pirut obsolete-not-provided up2date-gnome
E: pirut obsolete-not-provided rhn-applet

on pirut-1.2.10-1.fc7.src.rpm:
W: pirut unversioned-explicit-obsoletes system-config-packages
W: pirut unversioned-explicit-obsoletes redhat-config-packages
W: pirut unversioned-explicit-obsoletes pup
W: pirut unversioned-explicit-obsoletes up2date-gnome
W: pirut unversioned-explicit-obsoletes rhn-applet

These are a bit concerning, but based on our discussion on IRC, I have	
to agree that they're probably a necessary evil.  All of these packages
provided, at one time or another, the same functionality that pirut 
does.  They're all long gone from Fedora, probably never to come back. 
I'd suggest adding Provides for the Obsoleted packages, and perhaps 
versioning the Obsoletes, but I honestly can't say what the long-term 
side effects to that might be.	Ergo, I imagine we need to just go with
what we've got.  (Besides, it's already in Core.) 

4. I'm a bit concerned about pirut's use of /etc/xdg/autostart/ -- it's
owned by gnome-session, but I'm not seeing any sort of dependency on
gnome-session.	This might be a problem.

5. Open bugs.  Holy carp!  62 open bugs!

Address #2, #4, and maybe #5 and I think we may have a deal.




More information about the package-review mailing list