[Bug 379751] Review Request: emacs-common-ess - Emacs Speaks Statistics add-on package for Emacs

bugzilla at redhat.com bugzilla at redhat.com
Sun Nov 18 20:07:05 UTC 2007


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: Review Request: emacs-common-ess -  Emacs Speaks Statistics add-on package for Emacs


https://bugzilla.redhat.com/show_bug.cgi?id=379751


tibbs at math.uh.edu changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
               Flag|fedora-review?              |fedora-review+




------- Additional Comments From tibbs at math.uh.edu  2007-11-18 15:07 EST -------
rpmlint is down to just the four no-documentation complaints, which are OK. 
Everything looks good to me.

* source files match upstream:
   9531c53e534550924680862e10c04eadd9c049c66a1fc0b9df940c1f966c7a12  
   ess-5.3.6.tgz
* package meets naming and versioning guidelines.
* specfile is properly named, is cleanly written and uses macros consistently.
* Emacs packaging guidelines look to be followed properly.
* summary is OK.
* description is OK.
* dist tag is present.
* build root is OK.
* license field matches the actual license.
* license is open source-compatible.
* license text included in package.
* latest version is being packaged.
* BuildRequires are proper.
* %clean is present.
* package builds in mock (rawhide, x86_64).
* package installs properly
* rpmlint has acceptable complaints
* final provides and requires are sane:
  emacs-common-ess-5.3.6-2.fc9.noarch.rpm
   emacs-common-ess = 5.3.6-2.fc9
  =
   /bin/sh
   /sbin/install-info

  emacs-ess-5.3.6-2.fc9.noarch.rpm
   emacs-ess = 5.3.6-2.fc9
  =
   /bin/sh
   emacs(bin) >= 22.1
   emacs-common-ess = 5.3.6-2.fc9

  emacs-ess-el-5.3.6-2.fc9.noarch.rpm
   emacs-ess-el = 5.3.6-2.fc9
  =
   emacs-ess = 5.3.6-2.fc9

  xemacs-ess-5.3.6-2.fc9.noarch.rpm
   xemacs-ess = 5.3.6-2.fc9
  =
   /bin/sh
   emacs-common-ess = 5.3.6-2.fc9
   xemacs(bin) >= 21.5.28

  xemacs-ess-el-5.3.6-2.fc9.noarch.rpm
   xemacs-ess-el = 5.3.6-2.fc9
  =
   xemacs-ess = 5.3.6-2.fc9

* %check is not present; no test suite upstream.  Frankly I've no idea how to 
   test this so I'll trust the maintainer.
* owns the directories it creates.
* doesn't own any directories it shouldn't.
* no duplicates in %files.
* file permissions are appropriate.
* scriptlets are OK (texinfo index generation)
* code, not content.
* documentation is small, so no -docs subpackage is necessary.
* %docs are not necessary for the proper functioning of the package.

APPROVED

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.




More information about the package-review mailing list