[Bug 317581] Review Request: ruby-rpm - Ruby bindings for RPM

bugzilla at redhat.com bugzilla at redhat.com
Sun Oct 7 08:32:46 UTC 2007


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: Review Request: ruby-rpm - Ruby bindings for RPM


https://bugzilla.redhat.com/show_bug.cgi?id=317581





------- Additional Comments From mtasaka at ioa.s.u-tokyo.ac.jp  2007-10-07 04:32 EST -------
Some random comments:

* I guess you wrote
  http://fedoraproject.org/wiki/Packaging/Ruby ?
  Then please follow ruby guideline.
  - "Requires: ruby(abi) = 1.8" is needed
  - Also I usually add "BuildRequies: ruby(abi) = 1.8" for consistency.
  - This package should provide "ruby(rpm) = %{version}-%{release}".

* Change License tag
  http://fedoraproject.org/wiki/Licensing
  http://fedoraproject.org/wiki/Packaging/LicensingGuidelines
* Source must be given by full URL.
  http://fedoraproject.org/wiki/Packaging/SourceURL
* Please use the requested buildroot (check the section "BuildRoot tag"
  of http://fedoraproject.org/wiki/Packaging/Guidelines
* [ "%{buildroot}" != "/" ] && is not needed
* We now recommend %defattr(-,root,root,-)
* This does not be rebuilt on dist-f8.
  http://koji.fedoraproject.org/koji/taskinfo?taskID=185877
  On dist-fc7-updates-candidate, this can be rebuilt
  http://koji.fedoraproject.org/koji/taskinfo?taskID=185880
  At least "BR: popt-devel" is needed for F-8+.

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.




More information about the package-review mailing list