[Bug 457035] Review Request: libproxy - A library handling all the details of proxy configuration

bugzilla at redhat.com bugzilla at redhat.com
Mon Oct 20 13:52:55 UTC 2008


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.


https://bugzilla.redhat.com/show_bug.cgi?id=457035





--- Comment #12 from Joe Orton <jorton at redhat.com>  2008-10-20 09:52:54 EDT ---
It is possible to ignore the automatic shared library deps, but it's Really
Really Bad (TM), because you lose the ability to enforce ABI compatibility.

As I mentioned - I think the right thing to do for the example you give would
be to have firefox Require the mozjs plugins subpackage, if it's the case that
the latter depends on the former.  Everything still works automagically that
way.

(It may be necessary to achieve a critical mass of libproxy-enabled apps before
there is enough motivation to add these backwards -plugins dependencies)

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.




More information about the package-review mailing list