[Bug 453856] Review Request: globus-gsi-cert-utils - Globus Toolkit - Globus GSI Cert Utils Library

bugzilla at redhat.com bugzilla at redhat.com
Wed Apr 29 10:25:11 UTC 2009


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.


https://bugzilla.redhat.com/show_bug.cgi?id=453856





--- Comment #6 from Thomas Sailer <t.sailer at alumni.ethz.ch>  2009-04-29 06:25:10 EDT ---
Fedora review globus-gsi-cert-utils-5.5-1.fc10.src.rpm 2009-04-29

+ OK
! needs attention

+ rpmlint output
  See above; the "no documentation" warning can be ignored. Source Tarball does
not contain a license file
+ Package is named according to Fedora Package Naming Guidelines
+ Specfile name matches the package base name
+ Package follows the Fedora packaging guidelines
+ License meets guidelines and is acceptable to Fedora
  ASL 2.0
+ License matches the actual package license
n/a The package contains the license file
  none shipped by upstream tarball
+ Spec file is written in American English
+ Spec file is legible
+ Upstream sources match sources in the srpm
  48987f39031ac79949a9b0913aa42c67  ORIG/globus_gsi_cert_utils-5.5.tar.gz
  48987f39031ac79949a9b0913aa42c67  SOURCES/globus_gsi_cert_utils-5.5.tar.gz
+ Package scratch-builds
n/a ExcludeArch bugs filed
+ BuildRequires list all build dependencies
n/a %find_lang instead of %{_datadir}/locale/*
+ binary RPM with shared library files must call ldconfig in %post and
%postun
+ Does not use Prefix: /usr
+ Package owns all directories it creates
+ No duplicate files in %files
+ %files has %defattr
+ %clean contains rm -rf $RPM_BUILD_ROOT
+ Consistent use of macros
+ Package must contain code or permissible content
+ Large documentation files should go in -doc subpackage
n/a Files marked %doc should not affect package
+ Header files should be in -devel
n/a Static libraries should be in -static
+ Packages containing pkgconfig (.pc) files need 'Requires: pkgconfig'
  indirectly, via R: globus-core
+ libfoo.so must go in -devel
+ -devel must require the fully versioned base
+ Packages should not contain libtool .la files
n/a Packages containing GUI apps must include %{name}.desktop file
+ Packages must not own files or directories owned by other packages
+ %install begins with rm -rf $RPM_BUILD_ROOT
+ Filenames must be valid UTF-8

APPROVED by sailer.

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.




More information about the package-review mailing list