[Bug 507089] Review Request: olpc-powerd - power management for the XO laptop

bugzilla at redhat.com bugzilla at redhat.com
Thu Jul 23 00:54:04 UTC 2009


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.


https://bugzilla.redhat.com/show_bug.cgi?id=507089





--- Comment #9 from Christoph Wickert <fedora at christoph-wickert.de>  2009-07-22 20:54:03 EDT ---
(In reply to comment #7)
> rpmlint now gives 0 warnings/0 errors -- however, my development machine is
> currently fedora 9.  i did nothing for the "false positive" error that cwickert reported.  

I still get warnings for the binary package:

$ rpmlint olpc-powerd-8-1.20090720git702fd8e.fc9.i386.rpm 
olpc-powerd.i386: W: incoherent-version-in-changelog 8-1
['8-1.20090720git702fd8e.fc9', '8-1.20090720git702fd8e']
olpc-powerd.i386: W: devel-file-in-non-devel-package /usr/bin/powerd-config

The latter is bogus, the first is rpmlint not accepting the your changelog
style. However according to
https://fedoraproject.org/wiki/Packaging/Guidelines#Changelogs it is valid.


I have overlooked something, an issue from comment # 3 is still open:
- scriptlets should run silent. Add ||: at the end of the last command, so the
scripts will always return 0. If they return 1, rpm will abort the transaction.

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.




More information about the package-review mailing list