[Bug 571416] Review Request: GiGi-0.6.0 - C++ OpenGL GUI library

bugzilla at redhat.com bugzilla at redhat.com
Mon Dec 13 23:00:28 UTC 2010


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.


https://bugzilla.redhat.com/show_bug.cgi?id=571416

--- Comment #12 from Karel Volný <kvolny at redhat.com> 2010-12-13 18:00:24 EST ---
(In reply to comment #10)
> For FreeOrion :)

well, in that case you should also include the cmake modules that FreeOrion
uses ;-)

--- GiGi.spec.atkac     2010-12-08 13:45:45.000000000 +0100
+++ GiGi.spec   2010-12-13 16:36:00.431559469 +0100
@@ -53,6 +53,11 @@

 chmod +x $RPM_BUILD_ROOT/%{_includedir}/GG/gen_signals.py

+# add sources shared (used) by FreeOrion
+mkdir -p %{buildroot}/%{_datadir}/cmake/Modules
+cp cmake/Config.cmake %{buildroot}/%{_datadir}/cmake/Modules
+cp cmake/Util.cmake %{buildroot}/%{_datadir}/cmake/Modules
+
 %clean
 rm -rf $RPM_BUILD_ROOT

@@ -65,6 +70,7 @@
 %defattr(-,root,root,-)
 %{_includedir}/*
 %{_libdir}/pkgconfig/*
+%{_datadir}/cmake/Modules/*

 %changelog
 * Wed Dec 08 2010 Adam Tkac <atkac redhat com> 0.6.0-0.1.20101207svn903

(In reply to comment #11)
> How does this version compare with the 0.7.0 version available for download
> from the sourceforge site?  I know this package contains an SVN checkout but it
> seems odd that the version is behind what's available for download.

the problem is that the package is advertised as a newer version number, but
the authors forgot to change it within the sources so that it identifies itself
as the older version ... I see two solutions, one being used right now to keep
consistency with what really is in the source, and the other to patch the
sources to match the version written on the download page

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


More information about the package-review mailing list