[Bug 707389] Review Request: libwebp - Library and tools for the WebP graphics format

bugzilla at redhat.com bugzilla at redhat.com
Thu Jul 21 16:19:36 UTC 2011


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.


https://bugzilla.redhat.com/show_bug.cgi?id=707389

Veeti Paananen <veeti.paananen at rojekti.fi> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |veeti.paananen at rojekti.fi

--- Comment #1 from Veeti Paananen <veeti.paananen at rojekti.fi> 2011-07-21 12:19:35 EDT ---
rpmlint:

[veeti at veeti-pc result]$ rpmlint *.rpm
libwebp.src: W: spelling-error %description -l en_US WebP -> Web P, Web, Webb
libwebp.src: W: spelling-error %description -l en_US lossy -> loss, glossy,
flossy
libwebp.src: W: spelling-error %description -l en_US codec -> codex, code,
codes
libwebp.x86_64: W: spelling-error %description -l en_US WebP -> Web P, Web,
Webb
libwebp.x86_64: W: spelling-error %description -l en_US lossy -> loss, glossy,
flossy
libwebp.x86_64: W: spelling-error %description -l en_US codec -> codex, code,
codes
libwebp.x86_64: W: incoherent-version-in-changelog 1.0.2-1 ['0.1.2-1.fc15',
'0.1.2-1']
libwebp-devel.x86_64: W: spelling-error %description -l en_US WebP -> Web P,
Web, Webb
libwebp-devel.x86_64: W: spelling-error %description -l en_US lossy -> loss,
glossy, flossy
libwebp-devel.x86_64: W: spelling-error %description -l en_US codec -> codex,
code, codes
libwebp-devel.x86_64: W: no-documentation
libwebp-tools.x86_64: W: spelling-error %description -l en_US WebP -> Web P,
Web, Webb
libwebp-tools.x86_64: W: spelling-error %description -l en_US lossy -> loss,
glossy, flossy
libwebp-tools.x86_64: W: spelling-error %description -l en_US codec -> codex,
code, codes
5 packages and 0 specfiles checked; 0 errors, 14 warnings.

-----------------------

Some "informal comments":

- As mentioned by rpmlint, the changelog has an invalid version number.

- The build requirement for automake is unnecessary.

- The build requirements should probably be listed one per line.

- The devel package's base requirement should be fully versioned ("Requires:
%{name}%{?_isa} = %{version}-%{release}").

- The tools package should also require the base package.

- You should enclose all the macros like %buildroot, etc. in curly braces (
%{buildroot} ).

- libjpeg-devel and libpng-devel are probably needed for using libwebp-devel,
so those should be explicit requirements. (?)

- The files for the base package should be listed first. The -n %{name} part
would then be unnecessary.

- The files should be selected more verbosely:

- Since the development headers are all contained in one folder, replace the
"%_includedir/*" line with "%{_includedir}/webp/".

- Since there is only one pkgconfig file, just list it as "libwebp.pc".

- The tools package should use something like "%{_bindir}/*webp".

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.



More information about the package-review mailing list