[Fedora-packaging] perl module MODULE_COMPAT

Warren Togami wtogami at redhat.com
Mon Apr 4 09:51:37 UTC 2005


Ville Skyttä wrote:
> On Sun, 2005-04-03 at 15:19 -1000, Warren Togami wrote:
> 
> 
>>[root at fedora64 perl5]# ls
>>5.8.0  5.8.1  5.8.2  5.8.3  5.8.4  5.8.5  5.8.6  site_perl  vendor_perl
>>[root at fedora64 perl5]# pwd
>>/usr/lib64/perl5
>>
>>Hmm, FC4 still continues to have symlinks going back to 5.8.0 (RHEL3). 
>>I think this is a mistake.  We haven't maintained ABI compat that long 
>>right?
> 
> 
> What makes you think so?
> 
> 
>>Dirs should have been removed when they are known to be incompatible.
> 
> 
> Yes, but do we _know_ some of the above are incompatible?
> 

I recall Chip mentioning ABI broke sometime after 5.8.0.  Maybe I'm wrong...

Warren




More information about the packaging mailing list