[Bug 229065] New: double ?? in prepare causes seg fault on execute

bugzilla at redhat.com bugzilla at redhat.com
Fri Feb 16 19:30:27 UTC 2007

Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.


           Summary: double ?? in prepare causes seg fault on execute
           Product: Fedora Core
           Version: fc6
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: medium
          Priority: normal
         Component: perl-DBD-Pg
        AssignedTo: rnorwood at redhat.com
        ReportedBy: robert.haas at tekconnect.com
                CC: fedora-perl-devel-list at redhat.com

Description of problem:
If you attempt to prepare and execute a statement that contains "??", perl seg

Version-Release number of selected component (if applicable):

How reproducible:

require DBI;
my $dbh = DBI->connect('DBI:Pg:');
my $sth = $dbh->prepare("SELECT foo(??)");
$sth->execute(1, 1);

Steps to Reproduce:
1. Put the script above into a file
2. Fiddle connection string if necessary.  Any valid database will cause the
same result.
3. Feed it to perl.
Actual results:
Segmentation fault

Expected results:
Query gets executed and succeeds or fails or whatever the case may be.

Additional info:
I also tried this on an FC4 system with the same result, so it's not a new

Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

More information about the perl-devel mailing list