rpms/perl-Catalyst-View-Component-SubInclude/devel perl-Catalyst-View-Component-SubInclude.spec, 1.1, 1.2

Iain Arnell iarnell at fedoraproject.org
Thu Jul 1 15:13:10 UTC 2010


Author: iarnell

Update of /cvs/pkgs/rpms/perl-Catalyst-View-Component-SubInclude/devel
In directory cvs01.phx2.fedoraproject.org:/tmp/cvs-serv3027/devel

Modified Files:
	perl-Catalyst-View-Component-SubInclude.spec 
Log Message:
* Thu Jul 01 2010 Iain Arnell <iarnell at gmail.com> 0.09-3
- Require perl(Catalyst) >= 5.80014



Index: perl-Catalyst-View-Component-SubInclude.spec
===================================================================
RCS file: /cvs/pkgs/rpms/perl-Catalyst-View-Component-SubInclude/devel/perl-Catalyst-View-Component-SubInclude.spec,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -p -r1.1 -r1.2
--- perl-Catalyst-View-Component-SubInclude.spec	1 Jul 2010 14:46:11 -0000	1.1
+++ perl-Catalyst-View-Component-SubInclude.spec	1 Jul 2010 15:13:10 -0000	1.2
@@ -1,6 +1,6 @@
 Name:           perl-Catalyst-View-Component-SubInclude
 Version:        0.09
-Release:        2%{?dist}
+Release:        3%{?dist}
 Summary:        Use subincludes in your Catalyst views
 License:        GPL+ or Artistic
 Group:          Development/Libraries
@@ -10,6 +10,9 @@ BuildRoot:      %{_tmppath}/%{name}-%{ve
 BuildArch:      noarch
 BuildRequires:  perl(Catalyst::Action::RenderView)
 BuildRequires:  perl(Catalyst::Plugin::SubRequest)
+# perl-Catalyst-Runtime provides unversioned perl(Catalyst::Runtime)
+# Ensure that we really have a good version
+BuildRequires:  perl(Catalyst) >= 5.80014
 BuildRequires:  perl(Catalyst::Runtime) >= 5.80014
 BuildRequires:  perl(Catalyst::View::TT)
 BuildRequires:  perl(ExtUtils::MakeMaker)
@@ -20,6 +23,9 @@ BuildRequires:  perl(MooseX::Types)
 BuildRequires:  perl(namespace::clean)
 BuildRequires:  perl(Test::More) >= 0.88
 Requires:       perl(Catalyst::Plugin::SubRequest)
+# perl-Catalyst-Runtime provides unversioned perl(Catalyst::Runtime)
+# Ensure that we really have a good version
+Requires:       perl(Catalyst) >= 5.80014
 Requires:       perl(Catalyst::Runtime) >= 5.80014
 Requires:       perl(MooseX::Types)
 Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
@@ -62,6 +68,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/*
 
 %changelog
+* Thu Jul 01 2010 Iain Arnell <iarnell at gmail.com> 0.09-3
+- Require perl(Catalyst) >= 5.80014
+
 * Thu Jul 01 2010 Iain Arnell <iarnell at gmail.com> 0.09-2
 - remove automatically detected explicit requires
 



More information about the perl-devel mailing list