[perl-pip] 1.18 bump

Petr Pisar ppisar at fedoraproject.org
Thu Sep 16 16:20:42 UTC 2010


commit a77771d48bade016b398c69499c485f02a595940
Author: Petr Písař <ppisar at redhat.com>
Date:   Thu Sep 16 18:20:08 2010 +0200

    1.18 bump

 .gitignore    |    1 +
 perl-pip.spec |   15 +++++++++------
 sources       |    2 +-
 3 files changed, 11 insertions(+), 7 deletions(-)
---
diff --git a/.gitignore b/.gitignore
index 75d613c..becb5f7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,2 @@
 pip-1.16.tar.gz
+/pip-1.18.tar.gz
diff --git a/perl-pip.spec b/perl-pip.spec
index ba9ab25..c120cd5 100644
--- a/perl-pip.spec
+++ b/perl-pip.spec
@@ -1,6 +1,6 @@
 Name:           perl-pip
-Version:        1.16
-Release:        3%{?dist}
+Version:        1.18
+Release:        1%{?dist}
 Summary:        Perl Installation Program, for scripted and distribution installation
 License:        GPL+ or Artistic
 Group:          Development/Libraries
@@ -8,6 +8,7 @@ URL:            http://search.cpan.org/dist/pip/
 Source0:        http://www.cpan.org/authors/id/A/AD/ADAMK/pip-%{version}.tar.gz
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 BuildArch:      noarch
+BuildRequires:  perl >= 5.6.0
 BuildRequires:  perl(Archive::Tar)
 BuildRequires:  perl(Archive::Zip) >= 1.29
 BuildRequires:  perl(CPAN) >= 1.76
@@ -18,11 +19,10 @@ BuildRequires:  perl(File::Which) >= 1.08
 BuildRequires:  perl(IO::Zlib)
 BuildRequires:  perl(LWP::Online) >= 1.06
 BuildRequires:  perl(LWP::Simple)
-BuildRequires:  perl(Params::Util) >= 0.21
+BuildRequires:  perl(Params::Util) >= 1.00
 BuildRequires:  perl(Test::More) >= 0.42
 BuildRequires:  perl(Test::Script) >= 1.02
 BuildRequires:  perl(URI)
-Requires:       perl(Archive::Tar)
 Requires:       perl(Archive::Zip) >= 1.29
 Requires:       perl(CPAN) >= 1.76
 Requires:       perl(CPAN::Inject) >= 0.07
@@ -30,9 +30,8 @@ Requires:       perl(File::pushd) >= 0.32
 Requires:       perl(File::Which) >= 1.08
 Requires:       perl(IO::Zlib)
 Requires:       perl(LWP::Simple)
-Requires:       perl(Params::Util) >= 0.21
+Requires:       perl(Params::Util) >= 1.00
 Requires:       perl(PAR::Dist) >= 0.25
-Requires:       perl(URI)
 Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
 
 %description
@@ -76,6 +75,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/perl-pip
 
 %changelog
+* Thu Sep 16 2010 Petr Pisar <ppisar at redhat.com> - 1.18-1
+- 1.18 bump
+- Remove autodetected perl(Archive::Tar) and perl(URI) Requires
+
 * Wed Aug  4 2010 Marcela Mašláňová <mmaslano at redhat.com> 1.16-3
 - rename pip to perl-pip because it conflicts with python-pip 616626
 
diff --git a/sources b/sources
index 53b5294..58cdd81 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-93fa1c199f779ab0086a613fb7e18b56  pip-1.16.tar.gz
+61ccf13c50d2b485172748e46464b019  pip-1.18.tar.gz


More information about the perl-devel mailing list