[perl-Class-Autouse/f14/master] - Upstream update. - Adjust BR:'s. - Add %bcond_with xt_tests.

corsepiu corsepiu at fedoraproject.org
Fri Jan 21 07:27:13 UTC 2011


commit 2303ee24c57aeee9999184558a4d6e9bdcce9728
Author: Ralf Corsépius <corsepiu at fedoraproject.org>
Date:   Fri Jan 21 08:26:57 2011 +0100

    - Upstream update.
    - Adjust BR:'s.
    - Add %bcond_with xt_tests.

 .gitignore              |    1 +
 perl-Class-Autouse.spec |   66 ++++++++++++++++++++++++++++------------------
 sources                 |    2 +-
 3 files changed, 42 insertions(+), 27 deletions(-)
---
diff --git a/.gitignore b/.gitignore
index d6cbfe5..cf61adf 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,2 @@
 Class-Autouse-1.29.tar.gz
+/Class-Autouse-2.00.tar.gz
diff --git a/perl-Class-Autouse.spec b/perl-Class-Autouse.spec
index e49f105..43afde5 100644
--- a/perl-Class-Autouse.spec
+++ b/perl-Class-Autouse.spec
@@ -1,28 +1,34 @@
-Name: 		perl-Class-Autouse
-Version: 	1.29
-Release: 	9%{?dist}
-Summary: 	Run-time class loading on first method call
-License: 	GPL+ or Artistic
-Group: 		Development/Libraries
-URL: 		http://search.cpan.org/dist/Class-Autouse/
-Source0: 	http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Class-Autouse-%{version}.tar.gz
-# META.yml has wrong minimum perl version
-Patch0:		Class-Autouse-1.29.diff
-
-BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-
-Requires:  	perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
-BuildArch: 	noarch
-
-BuildRequires: 	perl(Test::More) >= 0.47
-BuildRequires: 	perl(Carp)
-BuildRequires: 	perl(File::Spec) >= 0.80
+Name:		perl-Class-Autouse
+Version:	2.00
+Release:	1%{?dist}
+Summary:	Run-time class loading on first method call
+License:	GPL+ or Artistic
+Group:		Development/Libraries
+URL:		http://search.cpan.org/dist/Class-Autouse/
+Source0:	http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Class-Autouse-%{version}.tar.gz
+BuildRoot:	%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+# Upstream does its very best to prevent us from running them.
+%bcond_with	xt_tests
+
+Requires:	perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
+BuildArch:	noarch
+
+BuildRequires:	perl(Carp)
+BuildRequires:	perl(File::Spec) >= 0.80
+BuildRequires:	perl(File::Temp) >= 0.17
+BuildRequires:	perl(prefork)
 BuildRequires:	perl(List::Util) >= 1.19
+BuildRequires:	perl(Test::More) >= 0.47
 
-# for improved tests
-BuildRequires: 	perl(Test::Pod) >= 1.00
-BuildRequires:	perl(prefork)
-BuildRequires:  perl(Test::MinimumVersion) >= 0.007
+# for xt tests
+%if %{with xt_tests}
+BuildRequires:	perl(Perl::MinimumVersion) >= 1.25
+BuildRequires:	perl(Pod::Simple) >= 3.14
+BuildRequires:	perl(Test::Pod) >= 1.44
+BuildRequires:	perl(Test::MinimumVersion) >= 0.101080
+BuildRequires:	perl(Test::CPAN::Meta) >= 0.17
+%endif
 
 %description
 Class::Autouse allows you to specify a class the will only load when a
@@ -32,10 +38,9 @@ large amounts of memory, and decrease the script load time.
 
 %prep
 %setup -q -n Class-Autouse-%{version}
-%patch0 -p1
 
 %build
-%{__perl} Makefile.PL INSTALLDIRS=vendor
+AUTOMATED_TESTING=1 %{__perl} Makefile.PL INSTALLDIRS=vendor
 make %{?_smp_mflags}
 
 %install
@@ -49,7 +54,11 @@ chmod -R u+w $RPM_BUILD_ROOT/*
 rm -rf $RPM_BUILD_ROOT
 
 %check
-make test AUTOMATED_TESTING=1
+make test
+%if %{with xt_tests}
+# Manually invoke xt-tests
+AUTOMATED_TESTING=1 PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" xt/*.t
+%endif
 
 %files
 %defattr(-,root,root,-)
@@ -58,6 +67,11 @@ make test AUTOMATED_TESTING=1
 %{_mandir}/man3/*
 
 %changelog
+* Fri Jan 21 2011 Ralf Corsépius <corsepiu at fedoraproject.org> - 2.00-1
+- Upstream update.
+- Adjust BR:'s.
+- Add %%bcond_with xt_tests.
+
 * Tue Jul 20 2010 Ralf Corsépius <corsepiu at fedoraproject.org> - 1.29-9
 - Reenable pmv test.
 
diff --git a/sources b/sources
index 5613bf5..9f4dfaa 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-da37cc729e01a504b93bc8bdc548d9a9  Class-Autouse-1.29.tar.gz
+84fbbad122191cb046ea5d96b2d51ac3  Class-Autouse-2.00.tar.gz


More information about the perl-devel mailing list