[perl-PPI/el5] Don't use macros for commands

Paul Howarth pghmcfc at fedoraproject.org
Sun Mar 18 12:43:43 UTC 2012


commit eb6487504a23fcab2bddff1ac5291d1a414d1270
Author: Paul Howarth <paul at city-fan.org>
Date:   Sun Mar 18 12:32:19 2012 +0000

    Don't use macros for commands

 perl-PPI.spec |   12 ++++--------
 1 files changed, 4 insertions(+), 8 deletions(-)
---
diff --git a/perl-PPI.spec b/perl-PPI.spec
index f4c3000..99d64ea 100644
--- a/perl-PPI.spec
+++ b/perl-PPI.spec
@@ -7,7 +7,7 @@ License:        GPL+ or Artistic
 URL:            http://search.cpan.org/dist/PPI/
 Source0:        http://www.cpan.org/authors/id/A/AD/ADAMK/PPI-%{version}.tar.gz
 Patch0:         PPI-1.201-UTF8.patch
-BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
 BuildArch:      noarch
 BuildRequires:  perl(Clone) >= 0.22
 BuildRequires:  perl(File::Remove) >= 0.22
@@ -21,7 +21,7 @@ BuildRequires:  perl(Test::ClassAPI) >= 1.02
 BuildRequires:  perl(Test::SubCalls) >= 0.01
 BuildRequires:  perl(Test::Object) >= 0.06
 BuildRequires:  perl(Test::Pod) >= 1.00
-Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
+Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
 
 %description
 Parse, Analyze and Manipulate Perl (without perl).
@@ -35,10 +35,9 @@ chmod -c 644 lib/PPI/Document/File.pm
 %patch0
 
 %build
-%{__perl} Makefile.PL INSTALLDIRS=vendor
+perl Makefile.PL INSTALLDIRS=vendor
 make %{?_smp_mflags}
 
-
 %install
 rm -rf $RPM_BUILD_ROOT
 make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
@@ -46,27 +45,24 @@ find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
 find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
 chmod -R u+w $RPM_BUILD_ROOT/*
 
-
 %check
 make test
 
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-
 %files
 %defattr(-,root,root,-)
 %doc Changes LICENSE README inline2test.conf inline2test.tpl
 %{perl_vendorlib}/PPI*
 %{_mandir}/man3/*.3pm*
 
-
 %changelog
 * Wed Mar 14 2012 Paul Howarth <paul at city-fan.org> - 1.201-2
 - Bump List::Util version requirement to 1.19 as per upstream
 - BR: perl(Task::Weaken)
 - Re-code docs as UTF-8
+- Don't use macros for commands
 
 * Wed Dec 19 2007 Tom "spot" Callaway <tcallawa at redhat.com> - 1.201-1
 - bump to 1.201


More information about the perl-devel mailing list