ruby 1.8.7p299 is now rawhide build tree

Mamoru Tasaka mtasaka at
Tue Aug 10 18:30:56 UTC 2010

Mohammed Morsi wrote, at 08/11/2010 01:49 AM +9:00:
> On 08/01/2010 02:52 PM, Mamoru Tasaka wrote:
>> <snip>
>>> ===
>>> BTW I tested this latest RPM in a VM and am happy to say via some light surface testing:
>>> rake, rack, rails, rspec, and gem work out of the box, and the puppet, rails, and deltacloud
>>> test/spec suites work in the same manner as they do against 1.8.6.
>> Thank you for testing. By the way, if rails 2.3.8 is ready, would you upgrade Fedora's rails
>> related packages to 2.3.8 for rawhide/F-14 for now?
> I just went through and cleaned up and updated the Rails 2.3.8 rpms.
> I uploaded the new srpms to my blog here
> All the issues that I could find are now taken care of, and the rpms
> work fine against Ruby 1.8.7 being shipped w/ F14.
> I tested rails as far as creating a new project, generating a new controller
> with a 'hello world' action / view, interfacing with the sqlite3-ruby gem,
> and running ./script/server and verifying the results. Everything worked as
> it should without errors.
> If anything looks off, shout out, else it would be good to start pushing
> for these to be updated in Fedora.
> -Mo

First of all, I appreciate your contribution to rails 2.3.8 srpms.

Well, I am not familiar with rails so I cannot do "detailed" test for new gem
related srpms. So for now I just took diffs of the spec files between on current
Fedora SCM and in your srpms. Then some notes:

- Would you check (and update) the dependency for each binary rpm?
   At least it seems
   - -actionpack rpm now should have R: rubygem(rack) >= 1.1.0.
     By the way current latest rack version is 1.2.1, however can actionpack (2.3.8)
     work with rack 1.2.x? actionpack 2.3.8 metadata seems to have "~> 1.1.0" dependency
     for rack, so rack 1.2.x and actionpack 2.3.8 seems incompatible "as it is".

- About activerecord-2.3.8-sqlite3-compat.patch in -activerecord srpm:
   - Does this patch work after sqlite3-ruby is updated to the latest?
     (i.e. is SQLite3::Version::STRING defined in sqlite3-ruby 1.3.1?)
     If not, I think the applied patch should be revised so that patches activerecord
     2.3.8 works with both sqlite3-ruby 1.2.4 (current Fedora) and 1.3.1 (latest).

     Something like  below?
     if current_adapter?(:SQLite3Adapter) && defined?(SQLite3::Version::VERSION) && SQLite3::Version::VERSION > '1.2.5'


More information about the ruby-sig mailing list