Rails/Rack version issue

Mamoru Tasaka mtasaka at ioa.s.u-tokyo.ac.jp
Wed Feb 24 02:06:29 UTC 2010


Jason Guiditta wrote, at 02/24/2010 06:47 AM +9:00:
> I am running Fedora 12 with Rails 2.3.4 installed.  Everything was 
> working fine, then last night I got an update from yum for Rack 1.1. 
>  After installing that, my working rails apps failed to load.  Creating 
> a new test app yielded:
> /usr/lib/ruby/site_ruby/1.8/rubygems.rb:827:in `report_activate_error': 
> RubyGem version error: rack(1.1.0 not ~> 1.0.0) (Gem::LoadError)
> 
> Has anyone else hit this issue?  If more detail is needed, let me know. 
>  Thanks,
> 
> -j

Well, as I already posted on 
http://lists.fedoraproject.org/pipermail/ruby-sig/2010-February/000055.html ,
rack 1.1.0 is not compatible with rails 2.3.x.
I added some workarounds on rawhide rails, however for F-12 we may have to
consider to downgrade rack to 1.0.0.

Regards,
Mamoru



More information about the ruby-sig mailing list