rubygem-rack in epel and fedora

Mohammed Morsi mmorsi at
Mon Sep 13 15:12:12 UTC 2010

  On 09/13/2010 08:31 AM, Michal Fojtik wrote:
> On 12/09/10 19:34 -0500, Michael Stahnke wrote:
>> I'd like to bump rubygem-rack to the latest (1.2.1) in Rawhide and
>> EPEL.  I was worried about EPEL and even started making a seperate
>> branch for a rack1 package, but according to my queries, the only
>> packages requiring rack in EPEL are:
>> EPEL:
>> stahnma at tyr /home/stahnma>  repoquery -q --whatrequires "rubygem(rack)"
>> rubygem-sinatra-1:1.0-2.el5.noarch
>> rubygem-shotgun-0:0.4-1.el5.noarch
>> F13:
>> stahnma at olive /home/stahnma>  repoquery --whatrequires "rubygem(rack)"
>> rubygem-actionpack-1:2.3.5-1.fc13.noarch
>> rubygem-actionpack-1:2.3.5-2.fc13.noarch
>> rubygem-merb-core-0:1.0.15-1.fc13.noarch
>> rubygem-shotgun-0:0.4-1.fc13.noarch
>> rubygem-sinatra-1:0.9.4-2.fc12.noarch
>> rubygem-sinatra-1:1.0-1.fc13.noarch
>> rubygem-thin-0:1.2.5-5.fc13.i686
> FYI: when I tried to use rack-1.2.1 with new Rack I got:
> (same error for Rails 2.3.5)
> <snip>
> /usr/lib/ruby/gems/1.8/gems/rack-1.2.1/lib/rack/utils.rb:138:in `union': can't convert Array into String (TypeError)
>    from /usr/lib/ruby/gems/1.8/gems/rack-1.2.1/lib/rack/utils.rb:138
> </snip>
> I'll contact Sinatra upstream to fix it.
>    -- Michal
I discovered and reported this issue (or at least a very similar one) a 
little while back. Its not a upstream problem, rather a Fedora packaging 
problem as we change actionpack 2.3.5 to be compatible with Rack 1.1.0

The problem is though we miss one important change which is causing this 
error. My updated patch to actionpack fixes this

I'm guessing this is a same or similar problem for sinatra.

We don't need this for actionpack 2.3.8 (shipping in F14+) though as by 
default it works with rack 1.1.0 and the whole patch is moot. I haven't 
backported this patch to Fedora 13 yet though, it is on my list, but 
keeps getting bumped down in priority.


More information about the ruby-sig mailing list