undeprecating rubygem-{bunny,moneta,ohai}

Julian C. Dunn jdunn at aquezada.com
Thu Nov 1 20:51:30 UTC 2012


Mo Morsi pointed me over here from -devel. I'm working on packaging Opscode Chef for Fedora and EPEL 6 (EPEL 5 is too old to do this sanely)

The first step for me is to un-deprecate the above packages. I have specfiles ready to go, except I have one question about "Requires: ruby(abi) = XXX".

What should the correct value be, given that I want to support EPEL 6 (has Ruby 1.8) and current Fedoras (have Ruby 1.9)? Is it acceptable to wrap this in a conditional, example:

%if %{?el6}
Requires: ruby(abi) = 1.8
Requires: ruby(abi) = 1.9.1

or not?

- Julian

More information about the ruby-sig mailing list