undeprecating rubygem-{bunny,moneta,ohai}

Vít Ondruch vondruch at redhat.com
Fri Nov 2 07:18:36 UTC 2012

Dne 1.11.2012 21:51, Julian C. Dunn napsal(a):
> Hi,
> Mo Morsi pointed me over here from -devel. I'm working on packaging Opscode Chef for Fedora and EPEL 6 (EPEL 5 is too old to do this sanely)
> The first step for me is to un-deprecate the above packages. I have specfiles ready to go, except I have one question about "Requires: ruby(abi) = XXX".
> What should the correct value be, given that I want to support EPEL 6 (has Ruby 1.8) and current Fedoras (have Ruby 1.9)? Is it acceptable to wrap this in a conditional, example:
> %if %{?el6}
> Requires: ruby(abi) = 1.8
> %else
> Requires: ruby(abi) = 1.9.1
> %endif

If you don't plan to support this package in F16, then this is just 
fine. However, please note that there is not available rubygems-devel 
package in EPEL6, so you will need to define also following variables 
for EPEL to keep the spec compatible between EPEL and Fedora

%global gem_dir %(ruby -rubygems -e 'puts Gem::dir' 2>/dev/null)
%global gem_instdir %{gem_dir}/gems/%{gem_name}-%{version}
%global gem_docdir %{gem_dir}/doc/%{gem_name}-%{version}
%global gem_cache %{gem_dir}/cache/%{gem_name}-%{version}.gem
%global gem_spec %{gem_dir}/specifications/%{gem_name}-%{version}.gemspec


> or not?
> - Julian
> _______________________________________________
> ruby-sig mailing list
> ruby-sig at lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/ruby-sig

More information about the ruby-sig mailing list