undeprecating rubygem-{bunny,moneta,ohai}

Darryl L. Pierce mcpierce at gmail.com
Fri Nov 2 14:24:52 UTC 2012


On Thu, Nov 01, 2012 at 04:51:30PM -0400, Julian C. Dunn wrote:
<snip>
> What should the correct value be, given that I want to support EPEL 6 (has Ruby 1.8) and current Fedoras (have Ruby 1.9)? Is it acceptable to wrap this in a conditional, example:
> 
> %if %{?el6}
> Requires: ruby(abi) = 1.8
> %else
> Requires: ruby(abi) = 1.9.1
> %endif
> 
> or not?

A note on specfile style: since we have a separate branch for each
target version, you don't need to use the above conditional. Instead, on
your el6 just use:

Requires: ruby(abi) = 1.8

and on F17+ us

Requires: ruby(abi) = 1.9.1


-- 
Darryl L. Pierce <mcpierce at gmail.com>
http://mcpierce.multiply.com/
"What do you care what people think, Mr. Feynman?"
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.fedoraproject.org/pipermail/ruby-sig/attachments/20121102/f022b9de/attachment.sig>


More information about the ruby-sig mailing list