undeprecating rubygem-{bunny,moneta,ohai}

Ken Dreyer ktdreyer at ktdreyer.com
Fri Nov 2 14:42:13 UTC 2012


On Fri, Nov 2, 2012 at 8:24 AM, Darryl L. Pierce <mcpierce at gmail.com> wrote:
> A note on specfile style: since we have a separate branch for each
> target version, you don't need to use the above conditional. Instead, on
> your el6 just use:
>
> Requires: ruby(abi) = 1.8
>
> and on F17+ us
>
> Requires: ruby(abi) = 1.9.1

Technically that's true, but it doesn't allow you to have a unified
spec file for all branches of Fedora and EPEL. It's quite nice to be
able to do fast-forward merges in Git, instead of having visible merge
commits, or instead of manually cherry-pick changes.

It's up to the maintainer to decide of course. I've just found it's
much easier to follow development on a package when the spec is
unified like this. EPEL in particular hangs around for a very long
time!

- Ken


More information about the ruby-sig mailing list