warning: rspec.rb provided by rubygem-rspec

Mo Morsi mmorsi at redhat.com
Tue Nov 13 22:02:58 UTC 2012


rspec1 shipped rspec.rb as part of the rubygem-rspec package

rspec2 shipped rspec.rb as part of rubygem-rspec-core, so to assist in
that migration we left rubygem-rspec at 1.x for the time, and converted
packages to depend on rspec-core. When the migration was done, we
updated rubygem-rspec.

rubygem-rspec was just updated in rawhide to 2.11.0 which again provides
rspec.rb (which was removed from rspec-core 2.11.0). So packages just
depending on rspec-core will now need to pull in rspec to be able to use
rspec.rb

The fix is easy enough, just a word of warning if you see related errs
in broken builds w/ gem packages starting in rawhide.

rspec also depends on an updated version of diff-lcs, which is available
in rawhide (thanks mamoru & vit!)

  -Mo



More information about the ruby-sig mailing list