Policy re Gems that don't have RPMs yet? - devise attempt

Vít Ondruch vondruch at redhat.com
Thu Jul 4 05:31:10 UTC 2013

Dne 2.7.2013 18:48, Philip Rhoades napsal(a):
> Vít,
> On 2013-07-02 15:47, Vít Ondruch wrote:
>> Dne 2.7.2013 00:27, Philip Rhoades napsal(a):
>>> Vít,
>>> On 2013-07-01 16:52, Vít Ondruch wrote:
>>>> Dne 30.6.2013 17:17, Philip Rhoades napsal(a):
>>>>> I tried changing the sections as you suggested but the errors are 
>>>>> still the same . .
>>>> Have you rebuild your SRPM actually? That must works. Show us your 
>>>> SRPM.
>>> It seems that is not getting built either:
>> You can build SRPM from .spec file using "fedpkg --dist f20 srpm".
> Whatever dir I execute that in, I get something like:
> Could not execute srpm: dirx is not a valid repo: [Errno 2] No such 
> file or directory: 'dirx/sources'

It complains you don't have the "sources" file in your directory. "touch 
sources" should fix this issue.

> BTW, that should be f18 in my case I think.
> Since the gem file has a tar.gz format, I thought that should go in 
> the SOURCES dir - should I actually find the devise tar.gz file and 
> put that there?

fedpkg is looking for sources in the same directory as the .spec file, 
no SOURCES directory is needed.

BTW gem with .tar.gz? Looks extraordinary. I would not recommend to 
follow this path.


More information about the ruby-sig mailing list