[Scitech] sagemath needs a lcalc package

Paulo César Pereira de Andrade paulo.cesar.pereira.de.andrade at gmail.com
Tue May 1 18:43:45 UTC 2012

2012/5/1 Jerry James <loganjerry at gmail.com>:
> On Sat, Apr 28, 2012 at 8:38 PM, Paulo César Pereira de Andrade
> <paulo.cesar.pereira.de.andrade at gmail.com> wrote:
>>  Hi,
>>  Not making an "official" package review request, but please review:
>> Spec URL: http://kenobi.mandriva.com/~pcpa/lcalc.spec
>> SRPM URL: http://kenobi.mandriva.com/~pcpa/lcalc-1.23-1.fc16.src.rpm
>>  It is not an official request because I just commented patch0 that is
>> required to build with pari 2.5.0, but fedora 16 has pari 2.3.5, and this
>> is another showstopper, as sagemath absolutely needs pari 2.5.0.
> I have been in touch with the pari maintainer.  He is preparing an
> update to 2.5.0, but some packages in Fedora still require 2.3.5.  The
> plan is to create a new pari23 package for those consumers who require
> 2.3.5, and push the main package to 2.5.0.  He asked me to help
> determine which consuming packages in Fedora can be updated to pari
> 2.5.0, and which must remain on 2.3.5.  I'll work on that this week.

  BTW, latest pari is now 2.5.1 :-) I believe it is "try and see" what builds
without any patches. Checking what needs previous pari should be just
check what is linked to  libpari-gmp.so.2 as pari 2.5.x now creates

> --
> Jerry James
> http://www.jamezone.org/


More information about the scitech mailing list