rpms/aqbanking/EL-6 .cvsignore, 1.9, 1.10 aqbanking.spec, 1.60, 1.61 sources, 1.9, 1.10

Bill Nottingham notting at fedoraproject.org
Thu Jul 8 20:37:05 UTC 2010


Author: notting

Update of /cvs/extras/rpms/aqbanking/EL-6
In directory cvs01.phx2.fedoraproject.org:/tmp/cvs-serv9822

Modified Files:
	.cvsignore aqbanking.spec sources 
Log Message:
sync with F-13



Index: .cvsignore
===================================================================
RCS file: /cvs/extras/rpms/aqbanking/EL-6/.cvsignore,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -p -r1.9 -r1.10
--- .cvsignore	5 Mar 2009 21:18:17 -0000	1.9
+++ .cvsignore	8 Jul 2010 20:37:05 -0000	1.10
@@ -1 +1 @@
-aqbanking-3.8.2.tar.gz
+aqbanking-4.2.4.tar.gz


Index: aqbanking.spec
===================================================================
RCS file: /cvs/extras/rpms/aqbanking/EL-6/aqbanking.spec,v
retrieving revision 1.60
retrieving revision 1.61
diff -u -p -r1.60 -r1.61
--- aqbanking.spec	24 Jul 2009 17:01:16 -0000	1.60
+++ aqbanking.spec	8 Jul 2010 20:37:05 -0000	1.61
@@ -1,32 +1,29 @@
 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
 
 %define qt3pkg qt
-%if 0%{?fedora} > 8
+%if 0%{?fedora} > 8 || 0%{?rhel} > 5
 %define qt3pkg qt3
 %endif
 
 Name: aqbanking
 Summary: A library for online banking functions and financial data import/export
-Version: 3.8.2
-Release: 2%{?dist}
+Version: 4.2.4
+Release: 4%{?dist}
 # Download is PHP form at http://www.aquamaniac.de/sites/download/packages.php
 Source: %{name}-%{version}.tar.gz
 Group: System Environment/Libraries
 License: GPLv2+
 URL: http://www.aquamaniac.de/aqbanking/
-Patch1: aqbanking-3.8.2-c++.patch
 Patch2: aqbanking-3.7.2-pkgconfig.patch
 Patch3: aqbanking-2.1.0-conflict.patch
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 # qbanking
 BuildRequires: %{qt3pkg}-devel
-# python
-BuildRequires: python, PyXML, gmp-devel
-BuildRequires: gwenhywfar-devel >= 3.4.1, libofx-devel >= 0.9.0, gettext, libtool
-Requires(post): /sbin/ldconfig
-Requires(postun): /sbin/ldconfig
+BuildRequires: qt4-devel
+BuildRequires: gwenhywfar-devel >= 3.10.0, gmp-devel, gettext, libtool
 Obsoletes: aqhbci <= 1.0.3
-Obsoletes: g2banking < %{version}
+Obsoletes: g2banking < 3.7.2-1 
+Obsoletes: python-aqbanking
 
 %description 
 The intention of AqBanking is to provide a middle layer between the
@@ -47,20 +44,18 @@ Requires: pkgconfig
 # for %{_datadir}/aclocal
 Requires: automake
 Obsoletes: aqhbci-devel <= 1.0.3
-Obsoletes: g2banking-devel < %{version}
+Obsoletes: g2banking-devel < 3.7.2-1 
 
 %description devel
 This package contains aqbanking-config and header files for writing and
 compiling programs using Aqbanking.
 
 %package -n qbanking
-Summary: Qt bindings for Aqbanking
+Summary: Qt3 bindings for Aqbanking
 Group: System Environment/Libraries
 Requires: %{name} = %{version}-%{release}
-Requires(post): /sbin/ldconfig
-Requires(postun): /sbin/ldconfig
 Obsoletes: aqhbci-qt-tools <= 1.0.3
-Obsoletes: kbanking < %{version}
+Obsoletes: kbanking < 3.7.2-1 
 
 %description -n qbanking
 This package contains the qbanking KDE bindings for the Aqbanking
@@ -72,32 +67,46 @@ Group: Development/Libraries
 Requires: %{name}-devel = %{version}-%{release}
 Requires: qbanking = %{version}-%{release}
 Requires: %{qt3pkg}-devel
-Obsoletes: kbanking-devel < %{version}
+Obsoletes: kbanking-devel < 3.7.2-1 
 
 %description -n qbanking-devel
 This package contains qbanking-config and header files for writing and
 compiling programs using the qbanking bindings for Aqbanking.
 
-%package -n python-%{name}
-Summary: Python bindings for Aqbanking
-Group: Development/Libraries
+%package -n q4banking
+Summary: Qt4 bindings for Aqbanking
+Group: System Environment/Libraries
 Requires: %{name} = %{version}-%{release}
+%{?_qt4_version:Requires:qt4 >= %{_qt4_version}}
+%description -n q4banking
+%{summary}.
+
+%package -n q4banking-devel
+Summary: Development files for q4banking
+Group: Development/Libraries
+Requires: %{name}-devel = %{version}-%{release}
+Requires: q4banking = %{version}-%{release}
+Requires: qt4-devel
+%description -n q4banking-devel
+%{summary}.
 
-%description -n python-%{name}
-This package contains python bindings for Aqbanking.
 
 %prep
 %setup -q
-%patch1 -p1 -b .c++
 %patch2 -p1 -b .pkgconfig
 %patch3 -p1 -b .conflict
 
 %build
 [ -z "$QTDIR" ] && . /etc/profile.d/qt.sh
-%{configure} --disable-static \
-  --with-kde3-libs=%{_libdir} \
-  --enable-libofx \
-  --enable-python
+
+%configure \
+  --disable-static \
+  --with-frontends="qbanking q4banking" \
+  --enable-qt4 \
+  --with-qt4-includes=%{_qt4_headerdir} \
+  --with-qt4-libs=%{_qt4_libdir} \
+  --with-qt4-moc=moc-qt4 \
+  --with-qt4-uic=uic-qt4
 
 make LIBTOOL=/usr/bin/libtool
 
@@ -120,6 +129,9 @@ mv $RPM_BUILD_ROOT/%{_datadir}/doc/{aqba
 mv AUTHORS README COPYING ChangeLog NEWS $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
 %find_lang %{name}
 
+# Fix multilib errors. (#602879)
+sed -i 's|** Created:.*|** Created |g' $RPM_BUILD_ROOT/%{_includedir}/q4banking/*.ui.h
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -131,50 +143,90 @@ rm -rf $RPM_BUILD_ROOT
 
 %postun -n qbanking -p /sbin/ldconfig
 
+%post -n q4banking -p /sbin/ldconfig
+
+%postun -n q4banking -p /sbin/ldconfig
+
+
 %files -f %{name}.lang
 %defattr(-,root,root)
 %doc %{_datadir}/doc/%{name}-%{version}
 %{_libdir}/libaq*.so.*
-%{_libdir}/aqbanking
-%exclude %{_libdir}/aqbanking/plugins/*/debugger
-%exclude %{_libdir}/aqbanking/plugins/*/frontends/qbanking
-%exclude %{_libdir}/aqbanking/plugins/*/wizards
-%{_libdir}/gwenhywfar/*
-%{_datadir}/aqbanking
-%exclude %{_datadir}/aqbanking/frontends/*
-%exclude %{_datadir}/aqbanking/i18n
-%{_bindir}/*-tool3
+%dir %{_libdir}/aqbanking
+%dir %{_libdir}/aqbanking/plugins/
+%dir %{_libdir}/aqbanking/plugins/*/
+%dir %{_libdir}/aqbanking/plugins/*/debugger/
+%dir %{_libdir}/aqbanking/plugins/*/debugger/*/
+%dir %{_libdir}/aqbanking/plugins/*/frontends/
+%{_libdir}/aqbanking/plugins/*/bankinfo/
+%{_libdir}/aqbanking/plugins/*/imexporters/
+%{_libdir}/aqbanking/plugins/*/providers/
+%{_libdir}/gwenhywfar/plugins/*/dbio/*
+%dir %{_datadir}/aqbanking
+%dir %{_datadir}/aqbanking/frontends
+%{_datadir}/aqbanking/backends/
+%{_datadir}/aqbanking/bankinfo/
+%{_datadir}/aqbanking/imexporters/
+%{_bindir}/aqbanking-cli
+%{_bindir}/aqhbci-tool4
 
 %files devel
 %defattr(-,root,root)
 %doc doc/0[12]* tutorials
 %{_bindir}/hbcixml3
-%{_bindir}/aq*-config
+%{_bindir}/aqbanking-config
 %{_libdir}/libaq*.so
-%{_includedir}/aq*
-%{_libdir}/pkgconfig/*
-%{_datadir}/aclocal/aq*
+%{_includedir}/aq*/
+%{_libdir}/pkgconfig/aqbanking.pc
+%{_datadir}/aclocal/aqbanking.m4
 
 %files -n qbanking
 %defattr(-,root,root)
-%{_bindir}/qb-help6
+%{_bindir}/qb-help8
 %{_libdir}/libqbanking.so.*
-%{_libdir}/aqbanking/plugins/*/debugger
+%{_libdir}/aqbanking/plugins/*/debugger/aqhbci/aqhbci-qt3-debug
+%{_libdir}/aqbanking/plugins/*/debugger/aqhbci/qt_debug.xml
 %{_libdir}/aqbanking/plugins/*/frontends/qbanking
-%{_libdir}/aqbanking/plugins/*/wizards
+%{_libdir}/aqbanking/plugins/*/wizards/qt3*
 %{_datadir}/aqbanking/i18n
-%{_datadir}/aqbanking/frontends/qbanking
+%{_datadir}/aqbanking/frontends/qbanking/
 
 %files -n qbanking-devel
 %defattr(-,root,root)
-%{_includedir}/qbanking
+%{_includedir}/qbanking/
 %{_libdir}/libqbanking.so
 
-%files -n python-%{name}
+%files -n q4banking
+%defattr(-,root,root)
+%{_bindir}/q4b-help1
+%{_libdir}/aqbanking/plugins/*/debugger/aqhbci/aqhbci-qt4-debug
+%{_libdir}/aqbanking/plugins/*/debugger/aqhbci/qt4_debug.xml
+%{_libdir}/aqbanking/plugins/*/frontends/q4banking
+%{_libdir}/aqbanking/plugins/*/wizards/qt4*
+%{_datadir}/aqbanking/frontends/q4banking/
+%{_libdir}/libq4banking.so.1*
+
+%files -n q4banking-devel
 %defattr(-,root,root)
-%{python_sitelib}/%{name}
+%{_includedir}/q4banking/
+%{_libdir}/libq4banking.so
+
 
 %changelog
+* Fri Jun 25 2010 Bill Nottingham <notting at redhat.com> - 4.2.4-4
+- fix multilib errors (#602879)
+
+* Fri Mar 19 2010 Rex Dieter <rdieter at fedoraproject.org> - 4.2.4-2
+- q4banking(-devel) pkgs (#571575)
+- better versioned g2banking/kbanking Obsoletes
+
+* Mon Mar  8 2010 Bill Nottingham <notting at redhat.com> - 4.2.4-1
+- update to latest upstream 4.2.4
+
+* Thu Jan 21 2010 Bill Nottingham <notting at redhat.com> - 4.2.3-1
+- update to latest upstream 4.2.3
+- obsolete the dead python-aqbanking package
+
 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng at lists.fedoraproject.org> - 3.8.2-2
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
 


Index: sources
===================================================================
RCS file: /cvs/extras/rpms/aqbanking/EL-6/sources,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -p -r1.9 -r1.10
--- sources	5 Mar 2009 21:18:18 -0000	1.9
+++ sources	8 Jul 2010 20:37:05 -0000	1.10
@@ -1 +1 @@
-195d3835f48cc54d59091e5c14a0eb86  aqbanking-3.8.2.tar.gz
+244f5c6e470b55452d9f2cb6c081c137  aqbanking-4.2.4.tar.gz



More information about the scm-commits mailing list