comps-f21.xml.in

Bill Nottingham notting at fedoraproject.org
Wed Dec 11 15:19:00 UTC 2013


 comps-f21.xml.in |  102 -------------------------------------------------------
 1 file changed, 102 deletions(-)

New commits:
commit b39b72179ebf73d26d7367cb5a1b37ce65ee5906
Author: Bill Nottingham <notting at redhat.com>
Date:   Wed Dec 11 10:17:47 2013 -0500

    Remove obsolete blacklist/whiteout metadata.
    
    anaconda has been modifed to no longer use the whiteout or blacklist
    plugins.  Nothing else uses them, so the metadata can go.

diff --git a/comps-f21.xml.in b/comps-f21.xml.in
index 8b5ec47..66ff5c5 100644
--- a/comps-f21.xml.in
+++ b/comps-f21.xml.in
@@ -6738,106 +6738,4 @@
     <match install="tesseract-langpack-%s" name="tesseract"/>
     <match install="tkgate-%s" name="tkgate"/>
   </langpacks>
-  <blacklist>
-    <package name="dev"/>
-    <package name="system-config-mouse"/>
-    <package arch="i386" name="NetworkManager"/>
-    <package arch="i386" name="dbus"/>
-    <package arch="i386" name="e2fsprogs"/>
-    <package arch="i386" name="esound"/>
-    <package arch="i386" name="gdb"/>
-    <package arch="i386" name="geomview"/>
-    <package arch="i386" name="gnome-applets"/>
-    <package arch="i386" name="gnome-panel"/>
-    <package arch="i386" name="hpijs"/>
-    <package arch="i386" name="kdeaccessibility"/>
-    <package arch="i386" name="kdebase"/>
-    <package arch="i386" name="kdeedu"/>
-    <package arch="i386" name="kdegraphics"/>
-    <package arch="i386" name="kdemultimedia"/>
-    <package arch="i386" name="kdemultimedia-extras"/>
-    <package arch="i386" name="kdenetwork"/>
-    <package arch="i386" name="kdesdk"/>
-    <package arch="i386" name="kdeutils"/>
-    <package arch="i386" name="kdewebdev"/>
-    <package arch="i386" name="kmymoney"/>
-    <package arch="i386" name="mysql"/>
-    <package arch="i386" name="nas"/>
-    <package arch="i386" name="perl"/>
-    <package arch="ppc64" name="NetworkManager"/>
-    <package arch="ppc64" name="dbus"/>
-    <package arch="ppc64" name="e2fsprogs"/>
-    <package arch="ppc64" name="esound"/>
-    <package arch="ppc64" name="gdb"/>
-    <package arch="ppc64" name="geomview"/>
-    <package arch="ppc64" name="gnome-applets"/>
-    <package arch="ppc64" name="gnome-panel"/>
-    <package arch="ppc64" name="hpijs"/>
-    <package arch="ppc64" name="kdeaccessibility"/>
-    <package arch="ppc64" name="kdebase"/>
-    <package arch="ppc64" name="kdeedu"/>
-    <package arch="ppc64" name="kdegraphics"/>
-    <package arch="ppc64" name="kdemultimedia"/>
-    <package arch="ppc64" name="kdemultimedia-extras"/>
-    <package arch="ppc64" name="kdenetwork"/>
-    <package arch="ppc64" name="kdesdk"/>
-    <package arch="ppc64" name="kdeutils"/>
-    <package arch="ppc64" name="kdewebdev"/>
-    <package arch="ppc64" name="kmymoney"/>
-    <package arch="ppc64" name="mysql"/>
-    <package arch="ppc64" name="nas"/>
-  </blacklist>
-  <whiteout>
-    <ignoredep package="XFree86" requires="Mesa"/>
-    <ignoredep package="XFree86-libs" requires="XFree86-Mesa-libGL"/>
-    <ignoredep package="arts" requires="kdelibs-sound"/>
-    <ignoredep package="aspell" requires="aspell-en"/>
-    <ignoredep package="bind" requires="bind-utils"/>
-    <ignoredep package="compat-glibc" requires="db1"/>
-    <ignoredep package="compat-glibc" requires="db2"/>
-    <ignoredep package="control-center" requires="xscreensaver"/>
-    <ignoredep package="coreutils" requires="pam"/>
-    <ignoredep package="cyrus-sasl" requires="openldap"/>
-    <ignoredep package="dbus" requires="dbus-glib"/>
-    <ignoredep package="ghostscript" requires="gimp-print"/>
-    <ignoredep package="ghostscript-fonts" requires="ghostscript"/>
-    <ignoredep package="gimp" requires="gimp-print-plugin"/>
-    <ignoredep package="glibc-debug" requires="glibc-devel"/>
-    <ignoredep package="gnome-python2" requires="gnome-python2-bonobo"/>
-    <ignoredep package="gtk+" requires="gdk-pixbuf"/>
-    <ignoredep package="gtk2" requires="scim-libs"/>
-    <ignoredep package="hicolor-icon-theme" requires="gtk2"/>
-    <ignoredep package="httpd" requires="httpd-suexec"/>
-    <ignoredep package="info" requires="ncurses"/>
-    <ignoredep package="initscripts" requires="kernel"/>
-    <ignoredep package="initscripts" requires="kernel-smp"/>
-    <ignoredep package="initscripts" requires="sysklogd"/>
-    <ignoredep package="initscripts" requires="util-linux"/>
-    <ignoredep package="kdemultimedia-arts" requires="kdemultimedia-libs"/>
-    <ignoredep package="libgnomeprint15" requires="gnome-print"/>
-    <ignoredep package="libtermcap" requires="bash"/>
-    <ignoredep package="lvm2" requires="kernel"/>
-    <ignoredep package="modutils" requires="vixie-cron"/>
-    <ignoredep package="mariadb" requires="perl-DBD-MySQL"/>
-    <ignoredep package="nautilus" requires="nautilus-cd-burner"/>
-    <ignoredep package="nautilus" requires="nautilus-mozilla"/>
-    <ignoredep package="ncurses" requires="gpm"/>
-    <ignoredep package="pam" requires="initscripts"/>
-    <ignoredep package="pango-gtkbeta-devel" requires="pango-gtkbeta"/>
-    <ignoredep package="perl" requires="mod_perl"/>
-    <ignoredep package="perl" requires="mrtg"/>
-    <ignoredep package="perl" requires="perl-Filter"/>
-    <ignoredep package="perl-Date-Calc" requires="perl-Bit-Vector"/>
-    <ignoredep package="php" requires="php-pear"/>
-    <ignoredep package="redhat-lsb" requires="redhat-lsb"/>
-    <ignoredep package="tcl" requires="postgresql-tcl"/>
-    <ignoredep package="usermode" requires="util-linux"/>
-    <ignoredep package="xemacs" requires="apel-xemacs"/>
-    <ignoredep package="xemacs" requires="xemacs-sumo"/>
-    <ignoredep package="xinitrc" requires="XFree86"/>
-    <ignoredep package="xinitrc" requires="xorg-x11"/>
-    <ignoredep package="xorg-x11" requires="Mesa"/>
-    <ignoredep package="xorg-x11-libs" requires="xorg-x11-Mesa-libGL"/>
-    <ignoredep package="ypbind" requires="yp-tools"/>
-  </whiteout>
 </comps>




More information about the scm-commits mailing list