[SOLVED] Re: Comment issue with the Server WG Blog

Adam Williamson adamwill at fedoraproject.org
Fri Dec 26 17:14:05 UTC 2014


On Thu, 2014-12-18 at 08:17 -0500, Stephen Gallagher wrote:
> 
> On Fri, 2014-12-12 at 11:00 -0600, Dan Mossor wrote:
> > On 12/12/2014 10:41 AM, Stephen Gallagher wrote:
> > > So, a number of people have written to me to let me know that 
> > > comments don't work on the Server WG blog. I took a look at it 
> > > today and discovered the following:
> > > 
> > > 1) Logging in with OpenID first seems to allow comments for me. I
> > > am unclear on whether that's limited to admin users.
> > > 2) Disabling the WP-Spamfree plugin restores functionality.
> > > 
> > > I'm inclined for the time being to just set all comments to 
> > > moderated and disable the Spamfree plugin. Any opposition?
> > > 
> 
> I set all comments to moderation as well as requiring an OpenID 
> login to post. That should keep the spam down and allow people to 
> comment properly.
> 
> The issue appears to be that WP-SpamFree hardcodes a path to a 
> standard set of functions in a WordPress install, but the OpenShift 
> layout does not match the standard install path, so it breaks. I 
> spent an hour or so trying to get it to work yesterday, but I 
> decided it wasn't worth the time. If someone else wants to deal with 
> it, let me know and I'll help get them access.
> 

I use akismet on happyassassin and it does a pretty good job. Don't 
know if it works with non-standard layouts.

Requiring OpenID to post is theoretically kind of pointless - see 
http://blogs.gnome.org/muelli/2014/12/wideopenid-woid-cryptobitch-de/ -
but spammers don't seem to have all gotten wise to that yet, so in 
practice it does help a bit...
-- 
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | XMPP: adamw AT happyassassin . net
http://www.happyassassin.net



More information about the server mailing list